Throttle High change rate with energy meter

I already found and read something about the Throttle High change rate.

Does the change rate really only apply to thr reactor sensor changing state or does it also mean that it gets many different values as input in a short time?

For my heater I placed a power walloutlet, which also measures the current power consumption.
Standby it is 1.8 Watt. I have a RS which reacts when the current consumption is > 10Watt. It then powers on the pump for the floor elsewhere in my house.

Today i saw the explanation mark with the high change rate. So that would mean, RS is inactive for a short period. When, that is not a wanted situation here, as the pump really should be turned on.

How can this be changed to a better situation? Or solved by changing the parameter?

I think you really need to examine the change rate of your logic. The default rates are pretty high for the kind of environment we’re working in. The default for MaxUpdateRate, which is the number of changes per minute that a ReactorSensor will allow before throttling, is 30. So are you saying your wall outlet is updating more frequently than 30 times per minute? Does that seem sensible and right given the mix of devices? That’s pretty suspicious to me. You haven’t published a Logic Summary with your question, so I can’t really advise you if anything in your logic might be causing high update rates. You can adjust the parameter, but if you don’t understand why the update rate is as high as it seems to be, all you could end up doing is destroying one or more devices, and possibly causing a hazardous condition that could lead to a fire. Don’t approach this casually. Before making any changes. please post a Logic Summary (as the posting guidelines for this category and the Reactor documentation request). As they suggest, the Logic Summary should be generate as soon after the problem manifests as possible (to capture the event list leading up to the issue), but in this case, we may be able to look at the logic alone and see if there’s a problem there. Adjusting the throttling parameters is rarely the right response. Usually logic adjustments to “dampen” response and provide some hysteresis is actually the correct (and safe) thing to do.

Thanks for the info, I understand what you mean. But looking at the values I still have this question (will try to genetare reports later).

This is what happening. The heater turns on, elektronics need energy, pump inside heater starts to run, so power consumption changes every second. For example I just used the device spy for the hourly checkup of it (don’t know what exactly is runnig) and that gives me 12 different power usage values within say 10-15 secons. So yes looking at that it is possible to have 30 values within 1 minute. Example values were:
1.7
2.4
38.4
26.5
26.5
16.8
46.2
17.6
2.5
2.4
1.7
1.8

And if you use hot water, turn heater really on, there are much more different values.
If RS only reacts (and go into throttle) > 10Watt, it still will be possible to have > 30 values.

But I only see here that it goes above 10, RS is activated and it goes < 10. So in my eyes it only turn on and off once. Why the throttle then?

The throttle reacts to the incoming inputs. If the input changes are very (very) close together, it causes only a single update of the RS (e.g. if 10 variables change at once, as long as they are close together in time, the RS starts reacting to the first and basically says “yes yes I’m working on it” for the rest). But if they are far apart (and one second is several million processor instruction cycles), then it’s likely the RS sees them as separate changes (which they are), each of which causes a re-eval of the RS condition(s).

If you look at the samples you gave, there are some big swings, and you probably don’t want your automation reacting to every one of them (which could risk short-cycling the controlled devices). You need hysteresis in this application, perhaps a time series or some other approach. A simpler approach would be a “sustained for” delay to dampen response. But in any case, I think the frequency of data from this device is too high, and if it’s configurable, I’d turn it down. Do you really want your mesh to be that busy anyway?

It’s a Fibaro FGWPE/F-101 and I use it out of the box.

As this scene is very simple, what if I will do it with vera’s own scenes?
Does Vera also work like RS? Or just >10Watt, do this, < 10 do that?

Still a bit confused, as yes there are many values, but it only goes above the threshold once.

Every time the value changes, the condition needs to be evaluated. This would be true of scenes as well. Every update is going to cause a process to wake up and consume CPU time. Whether or not the result of that evaluation generates any activity isn’t relevant–it’s trying to figure out if activity is needed.

By default, that module sends a power report every six seconds. You can adjust the reporting rate using advanced variables, in the range 5-600 seconds, according to the 102 User Manual. I would suggest exploring that option, to lessen network traffic as well as moderate the need for Reactor (or scenes) to keep running unnecessarily often.

Of course you are right, Vera must work like this also.

If I now look in the UI of Vera the displayed power usage is realtime, In RS it is “Watt”. Will look to the parameters. But watch out, the newer model 102 has some other parameters and default settings.

Downloading the manual at the moment, curious which parameter it must be then…

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules