TH8320ZW far

My last thermostat was fine, held a nice program, and worked great. It was an old Lux circa 1999. I live near a ski resort and broke my leg in three places training on the Olympic downhill run in Utah. Being on bedrest for a month was horrible. I had set the Lux previously to go to 60 degrees when we went to work. It was freezing in the house, and was HELL for me to get up and go to the thermostat. I decided it was time to upgrade. Yes, I could have just reprogrammed the Lux, but I needed an excuse. I really wanted a Nest, but I really didn’t want another device thrown in a box because it didn’t say Z Wave on it (I have a whole slew of stuff that with doesn’t work, or only half ass works.) I ordered the thermostat off Amazon and patiently waited. I got the thermostat, and my wife set me up with a bar chair and a TV table to wire that baby in. I take the old Lux off the wall…damn, 4 wires, problem #1. The box had a half ass 4 to 5 wire converter, but we all know how that usually ends up. So the heck with it, I call the pro’s in. Guy shows up, quotes $300+ to pull new wires. he has a 6 wire on the truck. I tell him I want at least 10, we are not going through this again. He says no, I ask if he can pull some network cable through. He says no. Damn 6 it is. He takes the Lux off, and cannot pull the wire through. Its stapled somewhere. WHY THE HELL DO THEY DO THAT…IDIOTS. He wires the dang converter up, and I know its going to be a disaster. (I would have never paid, but I am still in a cast.) It all goes together, he sets up the settings, which I read on Amazon that you needed an installer, of course any 8 year old can read and figure out you don’t need one. I ask him to take it off the wall so I can program it on the couch…no can do. If you take if off the wall, there is no such thing as programming it and putting it back on the wall like the 15 year old Lux. Fail #1. Next we get it to register on the Vera 3. Cool. Right before he left I look, and it is not showing up on the Vera…damn it. We finally figure out how to set it back to factory setting, because everytime we try to remove the thermostat it does not complete. We get it removed, and reinstalled. It now is back on the website, front end, or what ever you call that page. problem I have on the phone is when I go to the app, it gets lost in the fetching Vera loop. It just says fetching Veras, and either the phone times out or I get tired f waiting after 10 minutes. Also on the device when I try to set it as a node, it will not work…should have just got the Nest. I am sure after a week, I will get sick of it and it will go in the box with the rest of the crap.

Day 2 - there were 2 thermostats installed. Deleted one, solved numerous issues. Logged on from my phone at work, and changed the thermostat. Worked great. Still cant get the node to work, and ideas? Camera came in today, time to work on that.