[Solved] Lamp module showing temp

This may be more of a Vera issue than a Home Buddy issue, but figured I’d start here.
Just in the last couple of days I noticed in Home Buddy, one of my 2 Intermatic dimmable lamp modules started showing a temperature. It showed a temp of 60. I logged into Vera and cleared the temperature field on the device and saved, thinking this would solve the problem. Now Home Buddy shows just a line for Temp with no number.
Any ideas on how to fix this?
Attaching screenshot.

I reported this issue with the developer. He got back to me stating that he is pretty busy right now and will fix it when he can. I sent him a sample data so he can figure out what is going on.

  • Garrett

p.s. which version of vera firmware are you running?

Thanks for the info. I had been on 1.1.1047 for a long time but discovered a bunch of problems I had been having were due to the constant-reboot bug in that version, so I went back to 1.1.1036 which solved all of those issues. I have had 1036 running at least a couple of months before this HomeBuddy issue popped up.

I got an email response from rakstar. He said that he will get to fixing the issue sometime this week. He also wanted to remind me that he has been busy with work. I do appreciate him offering a great piece of software. He has come through in providing fixes for issues that have cropped up. A new data output was sent to him to fix a few other things as well. Looking forward to a new release.

  • Garrett

Thanks for the update.
:slight_smile:

@Solipsist sorry for the delay. you’re right, this seems to be a Vera issue… have you tried removing/re-adding the device? not sure if that would fix it but it’s worth a try. if it doesn’t fix the issue, i would contact MCV support.

No problem.
I am just too lazy to remove/re-add the module for a simple cosmetic issue at this point. I’ll wait until the next firmware upgrade, see if the CurrentTemperature field still exists on the module’s Advanced tab in Vera, and then maybe try re-adding if it persists.
Not a big deal for me though.
Thanks for the input.

Removing/readding should fix this, however included in the v0.19 rewrite is logic to only display information that the device actually supports.