[SOLVED] CT-100 thermosatat not responding

I’ve got a CT-100 thermostat that I’ve had installed for maybe a year or so. It’s been working fine with no complaints. It’s hooked up via the “C” wire but it has batteries in it as a backup. For the last few days, it doesn’t seem to be responding to Vera’s commands or queries for info. I’m getting the “Unable to get information on node” and the battery indicator has a question mark. Whenever I try and change a setting via the UI, it gives up after X retries. The funny part is that the thermostat does still seem to be sending status and Vera is picking up that. So I’m seeing the correct temperature and a scene I have for modifying the set point based on the outside temp can get the current setpoint with no problem, but it’s just not responding to inputs coming from Vera. It’s not a distance thing as the therm is fairly close to the Vera unit. I’ve tried repairing the Z-wave network (first just that device, then the whole network) but still no go. It’s possible the whole network repair still has some time to go, but I’m not sure.

Should I try and reboot the therm by taking out the batteries and cutting the power? Do they just sometimes get into a weird state?


Rebooting the thermostat as I described got it back working normally again.