[SOLVED] Altsteon & UI7 - Lua Engine Failed to Load

I finally updated to UI7 to try it out and am struggling getting the plm to work. I have my Insteon 2413U on a Raspberry Pi set up as per the earlier post. I can start Altsteon and connect to it by puttying into port 9805. I am able to send commands and get responses, so I know altsteon is working. Now, when I create the PLM device in Vera with the IP address set to the Pi, I get “Lua Engine Failed to Load”. Any thoughts?

I have tried running altsteon on both the Vera and the Pi with no luck. Any help is appreciated.

I’m running it the same way. No issues here. Does everything match this (aside from the IP): http://imgur.com/QaRdoqf

I_InsteonPlm.xml needs a code fix:

Lines 550 and 551 need to be switched:

return false, “Altsteon”, "Cannot connect to Altsteon on " … ipAddress

should be:

return false, “Altsteon”, "Cannot connect to Altsteon on " … ipAddress

I’ve attached the changes to this message. With this change I have ALTSTEON running and reporting status (SwitchLinc) on UI7!

Looks like another user was able to fix this. Try using this updated I_InsteonPlm.xml.

brbrice and joey,

Thank you both for your help. That fixed my issue!

Well that plus using the -r switch when starting altsteon.