single button scene controller won't start scenes

So associate it with a virtual switch (if it’s possible)…

It’s done at this point on the single button scene controller. These particular one button controller units are not worth arm wrestling with anymore.
They’ll be turned into what they’re specified for: Associations to a switch (or multiple switches) devices. I have no interest or time to patch these up and make them work as scene controllers. I’ve already wasted too much time on them. The PLEG testing was not conclusive (seeing now I didn’t have it tweaked quite right), but appears to be incredibly handy. I appreciate that.
On triggering scenes from a motion sensor:
Yes. We’re doing that in the guest bathroom. Worked fine out of the box. works fine now. Client is happy. I’m Pretty happy about that.

As for the ZRC-90US unit:
Support had to load a custom file into it to make it work. Apparently this was a known issue that will be fixed. It needed a modified JSON file (I believe). The original one Vera has for it was not correct. Was why it showed the “failed to load scenes” error.
They work as expected now with the modified JSON. Here’s the blurb from support:


Hello Kelly,

After you include ZRC 90, you have to go to the Advanced settings of the remote, and replace device_json parameter value with D_CentralSceneController1.json ,instead of the original one. Then click on ?New service? , → Reload engine. Wait for the engine to finish reloading, and then also refresh the page.

Then wake up the remote, by pressing W. Then re-assign the scenes to the buttons.

But this is just a temporary solution because I have reported it, and it will be resolved in the firmware with the next updates.

Regards,


Hope this helps somebody else.
Kellyl

I wish.
You can only associate with a real device.