Securing and stabilizing the Vera by taking it off the grid

Thanks chap. I can’t edit that. I get ‘Read only File System’ using vi…

C

I assume you are extrooted right?
If so, you need to overwrite the file which is a symbolic link with the actual file. Then you can edit it:

Use this to overwrite:

cp /usr/bin/Start_NetworkMonitor.sh /usr/bin/Start_NetworkMonitor.sh

Yes it means copy file into itself in linux which technically overwrites the link with the file.

Thanks

I’m getting a lot of Luup restarts recently. Let’s see what happens

C

Yup, let me know how this goes. I have been running it this way for almost a year now.

1 Like

Posting the latest version which is designed for 7.0.29. In the first post. This one also includes an experimental zwaveserial package which dramatically improved the zwave communications performance.

Rafale77 can / should I use this one or should I stick with the special one?

Cheers

C

@Catman

Either one will work. The update is more for people who have not done it yet. If you already used your special one, there is no need to do it again. Your version was shortened and simplified. This one is completely what I run on my test vera.

Cheers. Not done it yet as too far away to fix it should it go wrong. Mrs Catman would be severely disapproving if the heating failed. I’m more worried about the A/C :smiley:

C

Posting the latest version which is designed for 7.0.29. In the first post. This one also includes an experimental zwaveserial package which dramatically improved the zwave communications performance.

@rafale77 Is this the same zwaveserial upgrade you demonstrated in the 7029 Release Notes thread or anoher one? Ie,

SSH into the unit and check what repositories are listed in /etc/opkg.conf
There should be a new mios repo with this firmware version:

src/gz G450 http://dl.mios.com/firmware/mt7621_G450/openwrt/ramips/packages

If you don’t see it, add it.
Then run

opkg update
opkg list-upgradable

And see what you have available. Then run

opkg upgrade zwaveserial

The opkg.conf file you provide has a lot more repos than mine but I’m confused now as to which one contains the latest/greatest zwaveserial package…

src/gz mios_g450 http://dl.mios.com/firmware/mt7621/openwrt/ramips/packages
src/gz base http://archive.openwrt.org/chaos_calmer/15.05.1/ramips/mt7621/packages/base
src/gz packages http://archive.openwrt.org/chaos_calmer/15.05.1/ramips/mt7621/packages/packages
src/gz G450 http://dl.mios.com/firmware/mt7621_G450/openwrt/ramips/packages

opkg is smart enough to figure out which is the newest between the different repos. You don’t need to worry about it and can have both in your list. And yes the update includes the latest packages inclusive of the zwaveserial.

I see. OK, thanks. The version of zwaveserial I have since the upgrade is listed as:
zwaveserial - 1.0-2

What format is the mios_g550 file? On my old VeraLite the list of packages was just in plain text. But the VeraSecure file seems to be compressed - but with no extension…

No compression here. I actually use this repo on my plus as well…

Even using less or vi, the file is unreadable…

had a reboot problem i figured out the if you disable auto updates on all of you plugins it helps a lot with stability … so i tried it

I too just had a luup reload this morning which could be due to it getting disconnected from my ethernet network during a network firmware upgrade. I have disabled my plugin auto updates for quite some time though. I am trying to hunt down these last few nasty luup reloads…

mine been pretty solid its doesnt reboot unless i want it to

Not catastrophic… But I still want to stretch beyond the 10-15 days between luup reloads…

I am suspecting that one of the sources of luup reloads we have is… time adjustment from the ntpclient service. It appears that the luup engine reloads every time there is a time correction coming from the ntp which exceeds a certain amount (I am guessing 1s) and since the cpu on the vera does not keep time completely in sync with the ntp servers, the luup engine reloads every time it finds itself at odds. It might be the source of the ~2 weeks limit for the luup uptime.

1 Like

Simple fix would be to cron an ntpupdate job every 24 hours, then?

C

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules