Securing and stabilizing the Vera by taking it off the grid

Waking an old thread as I’m struggling with log uploads again.

I can’t for the life of me work out how I fixed it from this thread, but symptoms are that /etc/cmh/servers.conf has its log server entry owverwritten

/etc/hosts has a hard coded ip for that to my LAN FTP server:
192.168.70.250 oem-log3.mios.com

192.168.70.250 oem-log4.mios.com

ping oem-log3.mios.com
64 bytes from oem-log3.mios.com (192.168.70.250): icmp_req=1 ttl=64 time=0.381 ms

Using an ftp client I can log on to that ip with the user and pass in the servers.conf but…

Failed to upload file: /var/log/cmh/Init-NetworkMonitor.log_2019-12-01_18-09-11.gz

Failed to upload file: /var/log/cmh/InternetOk.log_2019-12-01_18-09-11.gz

Failed to upload file: /var/log/cmh/LuaUPnP.log_2019-12-01_18-09-11.gz

etc etc

Help?

C

Let me get this straight… are you trying to get the vera to upload these logs to another server?
Or are you trying to use the built in backup function to download your logs from a local server? Or are you uploading your log files to the mios servers? From your description, it sounds like the latter. I am not using the mios server and have disconnected from it a while ago (it was the point of this thread) but I am confused by your LAN ftp servers having a mios server address.

Sorry chap.
Trying to make Vera upload my logs to my personal FTP on site. This was the state before I upgraded to 7.30

The reason the Mios servers resolve to a local IP is that one of the fixes discussed was to edit /etc/hosts
Needed because somehow the host name (but not the user / pass) in servers.conf keeps getting overwritten…

Cheers

Fixed it I think. Nothing to do with DNS, but rather the limitations of the FTP server and its root folder. The issue is in /usr/bin/Rotate_Logs.sh:

curl -s -S -f --connect-timeout $CON_TIME --max-time $MAX_TIME -u “$ftpUser:$ftpPass” -T “$upLog” “ftp://$ftpServer/${pkap}/${pkap}_$(echo $upLog | awk -F ‘/’ ‘{print $NF }’)” 1>>$log_file 2>&1

I have to alter this to a path that makes sense…
C

Ahh… I see now. Thanks for clarifying. I am not sure this thread ever addressed FTP though so this is what got me confused. Good that you got it figured out.

The log upload is FTP. Let’s not go there!

C

@rafale77 I just upgraded to Firmware v.7.0.31 and followed your instructions to set up extroot again. I’ve been using Home Assistant in Docker on a Synology for a year to control zwave devices via the vera plus, and now i’m wondering how best to take the vera off the grid after the upgrade. Do these mods still work, or is there a better way? I see you have Nuke-Vera now, and I’m wondering if that might be the right path to turn the vera plus into a simple bridge for HA to use. Thanks so much for your efforts, and if you can point to me to any instructions, I’d be very grateful. All the best! Many thanks to you!

Sadly, @rafele77 got kicked off the Forum thus can no longer reply. He was our #1 contributor, so I hope someone equally knowledgeable and helpful can step up to fill his shoes! :frowning:

Dang @LibraSun that’s unfortunate. During “stay at home” orders, I decided to revisit my Vera/ HA configs for upgrades, and I may have ultimately “fixed something that wasn’t really broken”. I spent a couple of hours reading this forum, trying to catch up with all the changes in the last year, and it’s a lot to read (for sure). If anyone here can point me to instructions for running the Vera Plus off-grid, I’ll be eternally grateful. All the best.

1 Like

If you just use the zwave part, just block your Vera from accessing the internet using your firewall. This will work the same way.

Wait, what? How did @rafele77 get kicked off for spam? I have never seen a post with anything other than a fully reasoned and topical comment.

This site is now about 15% less useful and informative.

3 Likes

Thats insane hes one of the 3 best people here. Sorin must go.

2 Likes

I am curious as to what got him blocked and for how long. His messages are very helpful to those struggling with their setups.

2 Likes

Mcv doesn’t even know this forum (really the old one) is their biggest asset. #listentoyourusers

1 Like

A thousand year ban? That sounds excessive.
This is the opposite of good management.

2 Likes

Do not blame Sorin! He is a true patriot and had no hand in this.

2 Likes

He is the forum manager, who else could do that?

2 Likes

People higher in the organization.

2 Likes

I don’t think it was Sorin that banned him, so maybe best to give him the benefit of the doubt?

C

2 Likes

He’s currently blocked for 1000 years (roughly) I understand. For breaking forum rules

C

1 Like

I think we as a community all must be told why he was banned. This way he cannot even defend himself. Does he even know himself why he is?

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules