Schlage & Add Pin Failed

I have a Schlage lock (BE469NX) and tried to add an additional pin code to the lock. However, I am getting error “Add pin failed”. This is with UI7. Did anybody else experience this issue?

I had my locks configured for 6 digit pins. In vera I did go to Devices->[My lock]->Advanced. There I found the variables MinPinSize and MaxPinSize which were set to 4. I changed those to 6. Now I was able to add a new 6 digit pin in vera. However, it seems vera was not able to send that pin to the lock as the lock does not unlock when entering that pin. Further, when I go to the list of devices in vera then for that lock it shows an error message “Failed at: Setting user configuration…”. It seems I am a step closer but not quite there yet, if it’s possible at all.

I tried a few more times and it suddenly started working. Before when I added a pin I had “Show pin codes in clear” selected. After I unselected it and added a code that code worked. So I figured it has something to do with the “Show pin codes in clear”. But after setting that option again new codes still worked, though sometimes I had to try twice as the first trial failed with an error message. Vera seems to give me inconsistent and non-repeatable results/problems. In any case, it works now. Just set the MinPinSize and MaxPinSize which it seems are not read from the device but are internal variables in vera (at least I assume that as otherwise these numbers should be 6 and not 4).

Thanks for posting - this was the exact problem I had. Unfortunately, the VeraLite error is completely incorrect - instead of saying the PIN is too long, it says the PIN name or code already exists.

You are awesome! I wish I had googled this before troubleshooting myself.

I just got a BE369NX set up, but also have trouble adding pins. The problem is, it does not show any error. It just claims the pin has been set, but the pin just does not work. BE369NX only has 4 digits pin, so I don’t have to change that setting. Showing the pins or not does not seem to matter either. I am using UI7. Does anyone else have the same issue?