RFXTRX433e to VeraPlus via USB to ethernet

I need a "satelite"RFX in the garage, har anyone hooked one to the Vera using ethernet to USB device?

Should work. I had an Enocean wireless USB stick connected to my Vera over set of USB over ethernet adapters at one point…


I see the IP Address field in the serial port configuration, is that all i need to enter (together with the correct port), og do i need “Path” as well?

I’ll test it later today and report, but if anyone have a screenshot with working serial port settings, please post them. :slight_smile:

[quote=“Forzaalfa, post:3, topic:199115”]Cool!

I see the IP Address field in the serial port configuration, is that all i need to enter (together with the correct port), og do i need “Path” as well?

I’ll test it later today and report, but if anyone have a screenshot with working serial port settings, please post them. :)[/quote]

Wait - I thought you were just using an ethernet cable with USB adapters on each end. So no IP needed - you are just using a dedicated ethernet run to make a realllly long USB cable?

I have a wifi router out there connected to the main router by cable, and a ESP8266 running ESP Link to facilitate IP to Serial bridge. What i need in Vera is to simulate a Serial port that telnets to the ESP and talks serial.
I tested the old IPSerial plugin, and I entered IP and port 23 in the variables, but I can’t open the telnet link…

I’m already using this ESP link bridge to control my projector (RS232 to TTL in between ESP and projector), using LUA code to telnet to the ESP and send commands.

I see the “Path” and “IP Address” fields in the serial configuration in vera, anyone know how to use them?

Can anyone confirm that the IPSerial plugin works in UI7?

Just receieved confirmation from Vera that this functionality is not implemented yet, they just put in the IP field for the plugin to use!

I see in SSH log that its trying to connect to “IP:3487” which is the port of the IPSerial unit, an i can’t change that port for some reason…

BUMP: Anyone out there that uses IPSerial successfully? I need to know where the IP, and PORT variables go so the plugin connects using the right parameters… It seems to me that it uses the 3487 port that its given in serial config, and i can’t change it?

Slight update here: The RFXtrx433 is now hooked up to a beagleboard xM running Ser2net, and i discovered by coinsidence that the RFX plugin has some code for connecting to ser2net devices built in. If it’s given an IP before it i assigned to a serial port, it will try to connect to the IP instead.

The Port value is hard coded to 10000 though, this would be nice to have as a variable in “Advanced” GUI together with IP…

The problem now is that the plugin complains about bad messages from the IP RFX. Some devices were auto generated, but the data seems somewhat off. Anyone here who has tried this type of connection with the plugin?

I connected to the IP RFX using Domoticz and RFX Manager, and all works perfect there, so the Ser2net and RFX is working.

It’s possible that a port variable could be added to the plugin.
The problem may be with the protocol setting in the D_RFXtrx.xml file. This is set to raw. According to the wiki, possible values for protocol are cr, crlf, stxetx, or raw. I really don’t know if changing this will help. You’d have to make the change to the file and upload it to the Vera and then reboot? Maybe just removing the protocol parameter will help. Are there similar settings in Domoticz?

In Domoticz you just set IP and port, i’ll see if I can dig into which protocol it’s using. ser2net is set up to raw, as per the description i got from Bert:

3481:raw:0:/dev/ttyUSB0:38400 8DATABITS NONE 1STOPBIT

RFXManager is also working, so i think it should’ve worked from vera too?

I did change the hardcoded port to 3081 in D_RFXtrx.xml, so it connected OK.

Update: Im running openluup on the same beagleboard, and the plugin works fine running there into ALTUI. (I just put as IP).

The plugin is in other words fine, so i’ll try again from Vera too.

It works! I guess i have to be a bit more patient. after a while with some errors, all is well.

My compliments to the ppl behind the RFX plugin! :slight_smile:

I connected a RFX to a stationary computer and set up Serial-TCP on the computer… This worked eventually, but as this serial2ip converter didnt like that the port wasnt closed when vera rebooted, i had to put the following in D_RFXtrx.xml:


I also added a luup.sleep(500) in the L_RFXtrx.lua at line 4274 in the latest release.

Don’t know if this will affect a regular USB connected, but my other RFX connected by USB is working fine.

I’d still like to set up something to close the TCP connection on Luup reload, as it takes forever to reconnect(have to wait for the connection to time out)… Any suggestions on that is greatly appreciated!


I’m looking to make the jump and connect to my RFX-TRX433 remotely, by plugging it into a spare raspberry pi, running ser2net. Is there an updated device (D_RFXtrx.xml) or implementation file to help achieve this?

Also noting the earlier post, I seem to recall luup.sleep was not advisable; as I think it make all of Vera go to sleep not just the device associated?

This is a long time ago, and its probably true about the sleep, but this only happened at reboot, if i remember correctly. Didnt have any issues when i ran my rfx like this. :slight_smile: