Reset Vera Lite (Firmware v1.5.622)

I had selected Setup | Unit Settings | Do you want to secure this Vera? After doing so I could no longer access the controller since I did not know the authentication credentials. I figured I needed to do a hard reset, but found many suggested ways of doing it, but none worked for me. The information at may be correct, but was a bit confusing. I discovered that you had to double click the reset button located near the minus sign and hold it 10-15 seconds on the second click.

Hope this helps someone else. I spent many hours trying to figure this out.

Thanks…to be clear the “reset button” is next to the minus (need to use a paperclip or something), not the minus button itself, correct?

My unit is currently not responding. I’m not home at the moment, so I will try just a soft reset (unplugging / plugging in) first when I get there, but may need to resort to a factory reset and then restore prior settings.

I dare anyone to try and google how to factory reset your vera lite (using the hardware buttons), and find anything useful. Where did you find this info?

had same problem. frustrated could nor find reset How To. Tech support sent me this which worked.

  1. Connect your computer directly into the LAN port on the Vera lite unit
  2. Put a static IP on your computer ( and the gateway . You Can find
    more information about it at step 8.
  3. Plug the power adapter in Vera and when the blue light starts blinking, press and release
    the reset button
  4. Open a command prompt and telnet into the unit: telnet
    Run these commands:
    flash_eraseall -j /dev/mtd7
    echo b > /proc/sysrq-trigger


Seems your post is truncated… Could you repost for reference the entire sequence ? I suspect (though I so far did not have to test…) that the instructions posted at are obsolete…

Hi All,

I am having the same issue with a UI6 VeraLite. Was running fine until today I thought it would be good up finally change it to UI7. With 1.7.12 it is the first time the Vera prompted me to do it.
But, I am no longer getting past the blue light blinking and the firmware tool does not work (not seeing any adapter). I can telnet to the box using the instructions, but as the instructions seem incomplete I am stuck now.

Just glad I have my Egde still working :frowning:

Update: the reflash brought my unit back to live (thank god for old laptops with WinXP scattered around the house). So I thought I had to find a UI6 version to restore the backup and all to waist my Sunday. However, much to my surprise the box came up with the latest UI7 version and all my devices in apparently working order. A pleasant surprise for sure. Well done Vera :smiley:

Cheers Rene


Thanks for posting your reset instructions. It worked perfectly.

I bought a used unit off of EBay and it was still connected to the original owners account. i was having a VERY hard time finding info on how to reset. Your info did the trick. I now have a unit that is back to factory default setting.


Is there a downgrade firmware option for the epson xp 635?
i would like to load compatible ink cartridges which are
out there specifically for use with the xp 635.