Remove associations does not work

I have never succeeded in removing associations. I have fibaro units all over my house and on some places I have S2 associated to some other unit to be able to control it.

But when I use the Vera UI to remove association I can still control the other unit. Tried sending configuration several times. Heal network etc. Under advanced-tab ConfiguredAssoc, AssociationGet and AssociationSet is empty. Settings->Automatically configure is set to “Use default behavior”

The only way I can remove associations is to remove the unit from the z-wave network ant re-install it. But this is pretty annoying because then I have to go through all scenes and re-adding the unit again.

Anyone else experiencing these problems? Or have a solution?

I’m still on 1.5.408.

first of all… upgrade firmware.

Mmm, that is different from what @vublea had found here. Same device?

Yes, saw that issue earlier… Almost the same… but my asociation stays :frowning:

I have a 21,5kw device associated to a 3kw device in one place. And a dimmer assiciated to a 21,5kw device in another place.

Will try update to the latest beta soon to see if that helps me.

Updated to the latest public beta. Same result.

Just to clarify: so you have S2 control the second local load, as well as another Fibaro device. When you remove that association, S2 still controls the remote device?

If you associate it with another remote device, does that break the linkage with the original remote device?

Correct (in the 2x1,5kw case). For the dimmer it has no load on s2.

It was a while ao I tried this. But I remeber that it started controlling the other device aswell.

Are you just deleting the group? I have found that if I delete just the group, it simply removes it from the GUI. If I add the group back, the associations will reappear. I have to uncheck them, save a couple times, get the device configured, and then I can delete the group.

Thanks PureGuy.
Tried unchecking association, save, configure, remove group, save, configure. Multiple times. But the devices are still associated…

Using chome (and also tried in FF)
I have always done this on the controlling device. That is enough right? The controlled device never have any info that has to be removed right?

Hi Hek, do you still suffer this problem or did you find a solution in the meantime?
I have got the same problem here…

Still same problem. I always have to remove and re-include it into vera to remove associations permanently.

Luckily I don’t have to do it often…

I’ve had this happen with associations to multi-channel targets - like the second relay on a Fibaro FGS221. I find I can remove normal associations OK.

Once I’ve set a multi-channel association, I have found no procedure that will remove it apart from, as @hek points out, excluding and re-enrolling the sending device.

ah yes another bug in the UI… there is also no way to remove added services (in advanced) to a device… only way is deleting the device.
for the association you have to reset the zwave device itself to fabric settings in order to remove it.