Release Notes - Ezlo Linux firmware v. for Ezlo Plus and Ezlo Secure

We’re excited to release the new Ezlo Linux firmware v. for Ezlo Plus and Ezlo Secure controllers:

New Features:

  • Added Lua API for changing house modes using the keypad. Please note that the UI support for this feature will come at a later time with new mobile apps release.


  • Improved internet availability check on controller

  • Formatted scalable values in broadcast hub.device.setting.updated like hub.item.updated

  • Made changes so by default the sirens to be turned on immediately after a sensor is tripped.

  • Made changes so by default the sirens to be turned OFF in all house modes.

  • Improvements on the association interview process

  • Added support to power off (enter a stand-by mode) and power back on Ezlo Secure using the reset button. To initiate a power off (Stand-By mode) the reset/recovery button should be pressed 3 times during 1.5 seconds, you should see a fast yellow blinking emotion led.
    To initiate a power on plug an external power supply.


  • Fixed the issue with 3 videos created instead of 1 when recording
  • Fixed the Issue with Smart Start devices being add multiple times in some cases and breaking inclusion of other devices like cameras
  • Fixed the issues with Spontaneous Wi-Fi disconnects and Controller not reconnecting after a disconnect
  • Fixed the issues with Network Setting not being updated on some cases.
  • Fixed the issues with the camera Plugin scripts that was causing problems while adding camera
  • Fixed the issue with the motion sensor on VistaCam702 being armed after the firmware update
  • Fixed the issues with not being able to set the sirens to off from Preset Modes on relay connection
  • Fixed the issues with the low-resolution snapshots not working on VistaCam 702.
  • Fixed the issue on wireless onboarding that were occurring when the 4G/LTE was activated and mobile internet was available through the SIM card.

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state
  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)
  • Issue with incorrect sunrise/sunset time for scene in case the timezone is changed after enrollment. The sunrise/sunset scenes are calculated based on location and for the moment we do not have UI support to change it after enrollment (API is in progress of being integrated in UI)
  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF
  • Issues with some Door Locks, as Danalock V3, that are not added with S2 encryption

Hi @Ioana
the update is not done, I disconnected the network but nothing, I disconnected electrically and nothing too, the ezlo plus remains on version
Best regards

Same here. Unplug/plug network and power, but no firmware update.

Same here.

Hi @Ioana @Oleh
can we have on the next version of the application a drop-down menu with the versions and button “ok” or “download” to validate and make the update please?
Can we have the same to do a backup in order to restore a configuration that worked before the update please?

Best regards

1 Like

Guys, we are checking it now and will back asap.

1 Like

Currently, we are working on backup functionality, it’s one of our top priorities.



When we are using an Ezlo hub as our main production hub aka its then mission critical.

How do we stop automatic firmware updates?

I like to read the forums first for any posible issues or problems, before deciding to upgrade the firmware on my production Vera Plus by manually pressing the GO button.



Guys, the build is available for Ezlo plus.
Powercycle your hubs if you want to start update immediately.

Hi @Oleh
Thanks this worked with a hub.reboot command.

when will we be able to create a virtual device from adding devices?

when will we be able to send http requests just from the scenarios?

Best regards


Just to clarify.
Do you mean to create a virtual device with a dedicated API request or directly from the mobile app?

Do you mean scenes or Lua scripts?

Hi @Oleh
I want to create a virtual device from the application, using the menu “Devices” => then “virtual device”.

I want to be able to send http requests from scenes and also from scripts. Can you add in the scenes a menu which would be in the “Action” => then “Add request http”

Since the update all my thermostats went from C to F jow can i change back the controller to celsius?

Hi @eonnet,

The hub started to use the settings, but the apps are not ready for that yet (wrong order if you ask me). Here are ways to fix: Beta feedback Ezlo Plus - #655 by reneboer - Beta Discussions - Ezlo Community

Cheers Rene

1 Like

I wish I would see a temperature at all. That’s all I get from the app:


I only see that there is a device :wink: