Re-establishing communication between Vera and Kwikset?

I have a Kwikset deadbolt that I have been using with my Vera Plus quite successfully for the past few years. Yesterday, after I did an engine reload on the Vera Plus, said door lock apparently stopped communicating with the Vera Plus. Nothing I have tried so far has restored communications. Here is what I have tried, more or less in order:

  1. Removing/replacing batteries in the door lock (after checking that all have a full charge)
  2. Choosing the “Poll” option from advanced (gives a timeout error)
  3. Restarting the engine again from Advanced → New Service → Reload Engine (no change detected)
  4. Restarting the vera controller from Settings → Net and WiFi → Reboot (no change)
  5. Going to “Add Device” and re-including the door lock (shows “Existing Node Detected”, indicating that it is communicating, but still doesn’t restore functionality)

I am quite loathe to actually remove the lock and try re-adding it, as it is used in quite a few Scenes, both for actions and triggers, and I’d rather not have to figure out where all it is referenced and rebuild everything again if at all possible. Is there anything else I can try?

I don’t know about locks but I have used the “Replaced Failed” quite successfully for switches and dimmers. Basically, it replaces the original device with a different one without changing the device ID.

1 Like

Hello! @ibrewster

You could also try to bring the controller to the lock to poll it and see if it responds/updates the status when manually use.

  • Go to Settings > Net & Wi-Fi, and select connection through a Wi-Fi access point.

  • Set up the Wi-Fi connection and bring the controller closer to the lock once it’s online without the ethernet cable.

  • Poll the device and manually use it to see how it reacts. Let us know if the lock is not communicating.

Lock remains in a non-communicating status, but now the vera is saying “Can’t Detect Device”, which is new. I tried clicking the “Replace Failed” button under Advanced–> commands, which gave me a popup message saying “Command executed successfully”, but nothing else seemed to happen, so I’m not entirely sure what that command is supposed to do.

Maybe my lock just decided to die? That would be annoying, but I suppose it’s possible…

For what it’s worth, the devices are only separated by about 12-15’ (that lock is one of the closest devices to my controller, other than a couple of switches), and as I mentioned it has been working flawlessly for years. That, coupled with the fact the controller does see it when I try to add a device (though it doesn’t actually do anything after stating “existing node detected”) makes it seem to me that range isn’t the issue here (though obviously I am not the expert…)

Hello @ibrewster

If you prefer we can create a support ticket for you and we will contact you for more personalized troubleshooting.


Jonathan Botero.
Customer Care Tier 1 Support.

Worth a shot I guess. Sort of feels like I’ve tried the obvious stuff, given the lack of other suggestions. Thanks.

Replace failed starts a special inclusion process that retains the device id after a new device of the same make and model is added.

For example, I have some z-wave LED bulbs. To reset them to the factory defaults, you turn them off, then on 4 times within 4 seconds. During severe weather events (e.g. Hurricane Ian), the power lines flicker causing these bulbs to reset. So, I run Replace Failed for each bulb to bring them back into the network as they were before they were reset. I just did this with 3 bulbs this weekend, 2 worked the first time, the 3rd had to be reset and brought closer to the Vera to complete the replaced-failed inclusion. However, all my device ids were retained and all the scenes were left intact.

So for your lock, you may want to try Replace Failed and then do whatever you need to do to the lock itself for a normal network inclusion (e.g. push button, connect batteries) and see if that works. If it doesn’t, then factory reset the lock and then try Replace Failed and start the normal lock inclusion process as if it were brand new. If all goes well, the Vera will re-include the lock using the existing lock ID.

This is the process that I have used countless times quite successfully over the years but never with a lock.

That’s more-or-less what I expected to happen, but it didn’t. I Simply get a message saying “Command executed successfully” and nothing else happens - the Vera never goes into inclusion mode. Weird.

The Vera actually does go into inclusion mode, it just doesn’t show in the web browser for some reason, at least not in Safari on macOS. However, my devices actually were included; in the case of LED bulbs, they blink twice when included providing a visual indicator of success. Once they blinked, I waited a couple minutes and tried to turn them on, off and dim via the web browser and it worked. If you have ssh access, you could watch the log using tail -f /var/log/cmh/LuaUPnP.log

Ahhh, gotcha. With that in mind I tried again, pressing the proper button on the lock, but while I got a red light on the lock (same as when I try a regular inclusion and get the “Existing node detected” message), it doesn’t seem to help anything. So that doesn’t look promising for the lock, I guess.

Have you tried factory resetting the lock first? Factory resetting the lock will “erase” / reset the z-wave network information so it can be included in a z-wave network. You don’t want to exclude it using the Vera because that will remove the device id from Vera (i.e. in order to use Replace Failed, the device needs to exist).

Yes - though I’m not 100% convinced the reset procedure worked as expected, since the lock still remembers my code. I would think a “real” reset would have wiped that out. I’ll see if I can find reference to some other reset - maybe what I found is for a different model or something.

1 Like

So the factory reset finally seemed to work - but not until after I conceded defeat and unpaired the lock from my Vera. After the unpairing process completed, I ran the reset procedure, verified that my code did not work on the lock anymore, thus indicating that it had, presumably, actually reset, then re-paired the lock with the vera.

The pairing process ran smoothly, and after re-programming all the scenes involving the lock, things now appear to be functioning correctly again.

Would have been really nice if I had been able to get the “Replace Failed” feature to work, but oh well - all’s well that ends well, as they say :slight_smile:


It’s a good thing you figured this one out. I had a Kwikset connected to Vera for 2-3 years before it stopped working with the hub. I tried everything. Waited a year, tried everything again. Eventually, I gave up and got rid of the Kwikset and used one that doesn’t communicate with Vera directly (has its own ecosystem, but does work with Alexa/Google). That lock has been working fine ever since. I just don’t really use Vera in the mix.

1 Like

Yeah, in my case that would defeat most of the point of having a home automation system, as the Vera has all the devices and runs all the automation. Now if the vera (or my Ezlo plus) device could communicate with Alexa, such that it could command an alexa device to do something, that might work (though it would need to be two-directional - I need to be able to respond to the door unlocking, for example), but that’s not an option at the moment.

Ya, there was some compatibility for that with the Ezlo Plus, but ours ended up going kicks-up in around a year or less. At that point both parties confirmed the unite was dead. Going back to the VeraPlus took those options away so we wound up taking a break and moved to HA for now. Not fully committed to HA as there is a monthly/yearly fee for Alexa/Google support, so will either move back to Ezlo some day or wait for a similar option that is as open as the Vera’s were to custom code/script that is Matter supported.

Perhaps at first, but the “Ezlo VOI” feature has been broken for a year or more - you can still control Ezlo devices from Alexa, but you can’t do anything with Alexa devices from Ezlo. Sadly, there seems to be no indication that this will ever be fixed :frowning:

Doh! That’s is unfortunate, indeed. If that remains to be the case, might just stick with the idea of waiting to see what happens when Matter options start popping up.