PLEG app cannot be uninstalled

Hi all,

This is on a Vera3 UI7 1.7.541

As I was playing with VeraAlerts and notifications in PLEG, I got into a state where if I hit the “Status” button in the PLEG device page, it would always cause the browser to pop a dialog asking for my password (even though I was already logged in) and it would always fail. So after 3 attempts it would pop a message saying “Error communicating with Vera” and I would be back to Vera’s UI. Everything else seemed to work ok, except that my triggers, conditions, etc would not show up in PLEG.

In an attempt to fix the problem I decided to uninstall PLEG. That didn’t work – Vera would tell me the app had been uninstalled by PLEG would never be removed from the “My Apps” list. I tried removing PLC (Program Logic Core), which PLEG depends on, and that succeeded but I still can’t seem to be able to remove PLEG. I also tried rebooting. No luck.

Does anybody know what’s going on?


Update: I was able to uninstall PLEG by using Chrome (I was using IE 11 before). Not sure why PLEG though as I was able to remove other apps before with IE.

Glad it worked. I am using IE 11 and uninstalled PLEG a few times without issues. I am not saying that your issue wasn’t related to IE 11 but it’s also possible that vera was not behaving as it should have.

There are many known issues with IE, especially IE 11, and Vera. You’re much better off using Mozilla or Chrome against Vera.

I’m starting to realize that as well. Position of some of the elements in the Devices area is screwed up as well (they look slightly better in Chrome). However, Chrome is not always at hand when I need it unfortunately.