Philips Hue Firmware 24th Feb Breaks Plugin

cough… ALTHUE… cough… cough

3 Likes

Well… I gave up and switched to AltHue plugin. Although I have to adapt several scenes. Which is for me also a good reason to use Reactor for this in stead of the limited scene capabilities of Vera.
Again an example that we luckily have a bunch of very capable external plugin writers. Much more capable and quicker than Vera team (sorry to say so…). @amg0 and @rigpapa igpapa thanks again for you excellent plugins!

3 Likes

Yes. My Hue Bridge firmware upgrade failed on 24-Feb.

Thanks for the recommendations everyone. Sounds like ALTHUE or Reactor are options.
I am not terribly impressed with Philips Hue. The scenes are very limited.

I will not loose more time to check the old plugin and start with AltHue. If you are able to maintain the devices and want to preserve scenes (to some degree, since AltHue is using standard actions, while the official one goes for proprietary ones…) you can

  • restore a backup
  • remove the embedded flag from the child devices (this should prevent a delete) before they get deleted
  • install AltHue
  • run a discovery
  • swap device ID, as previously shown

This will preserve scenes. If you are able to start from scratch, just do it and never look back. AltHue is very well maintained and it’s working with standard actions, so 100% compatible with mobile apps.

EDIT: and I wish it was possible for the community to flag a plug-in as not working and have the AppStore reflect this, to prevent new users not accessing the forum from installing non-working things and get frustrated. There’s a long list of scenarios like this…

3 Likes

Agreed. I also dumped the old Plugin yesterday and installed AltHue due to that all my bulbs were deleted. I will not look back.

1 Like

Bit the bullet and moved over to AltHue - creating a second device as I need two Hue Bridges. It took a press of the button on the Hue Bridges and a couple of Engine Reloads to get things working, but all devices in and working and added back into the scenes.

2 Likes

Cheers, I just used the AltHue plugin to restore my 3 Hue lights - even that was painful so Im glad I only had 3!

1 Like

I have also installed AltHue a while ago and my devices are shown again.
But I can’t find any coloreffects like colorloop etc.

Is this still possible in AltHue?

Yes use the “SetEffect” option “newEffect” = colorloop

Ok many thanks.

As soon as my Vera is working again ( I updated to the latest firmware and can’t connect to Vera at all anymore) I will try this. Do you happen to know if it is also possible to adjust the colorloop speed?

I am not aware that can be done no.

Indeed, a recent firmware update on the Philips Hue bridge seems to have broken the Hue2 plugin when the manufacturer was renamed from “Philips” to “Signify”. Here is a fix. Just unzip this file and drop L_PhilipsHue2.lua over your old one in apps -> Develop apps -> Luup files and you should be back and running.

I have already informed Vera tech support of this issue.

L_PhilipsHue2.zip (15.4 KB)

I had tried making that change, just not in the .lua file. Thanks for sharing. I have moved to Althue, although that has some issues related to being able to control the ambiance of the white ambiance bulbs.

I’ll give your fix a go later. Thanks again.

I’m back up and running. Thanks for posting the fix @gengen.
Not sure why Vera couldn’t get a fix out.
And Vera closed my support case without providing a real solution.

Is this just a bug or compatibly issue with the latest version of Safari, it seems to display fine in Chrome and on the mobile app?

It looks like Vera updated the Hue 2 app and now on Chrome and Safari the bulb icon is missing.

1 Like

Hello,

Indeed we have released a new version for the plugin, 1.79, for more details please check this thread.

Can you please share with us the Philips hue model that you have so we can investigate this issue?

Thanks!

The bulb model is a LTW015 (Hue Ambiance)
To update:
“It looks like Vera updated the Hue 2 app and now on Chrome and Safari the bulb icon is missing.”
Bulb icons are missing in Chrome. Bulb icons are there in Safari just no slider and on/off as shown in picture of previous post.

Ok, I’m trying to get this working. But where do you do this?
I don’t recognize the screenshot. In what menu can I set this?

hello man,

can you help me using the ALTHUE? I cant make the bridge pair…

hi, can you help me getting my hue bridge work with vera again???
I installed the 1.79 version but the bridge wont pair!
Bridge Model BSB002
Firmware version 1938112040
this is very frustrating

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules