openLuup & (not) vera

Full migration is complete and more. I added the icon for the barometer device type which was a zigbee endpoint vera did not support but ALTUI did. It was just missing a good icon. It was quite a bit of work given the amount of devices I have but I have now full access to all the sensors of my zigbee devices. The vera would only see one of the two smoke/CO sensors and as I said was missing pressure measurements.

I am absolutely thrilled by this solution. The system (openLuup/ALTUI/Zway/Home Assistant) all running in one machine has reached rock solid stability, full feature/device support and no latency running over a dozen vera plugins along with pretty much anything you can imagine for integration.

This goes to emphasize how powerful this community (and the home assistant one) are. To @blacey’s point. None of this would be possible without he contributions of @akbooer, @amg0, @rigpapa, @reneboer who wrote all the plugins I couldn’t write myself.

I found very ironical that I started looking to stabilize the setup by suspecting the hardware and ran the whole vera firmware in a much more powerful machine, updating packages OS and kernel to finally end up with using the vera plus hardware with all of the mios software disabled replaced with nearly all community developed software. It’s been a long journey…

It is not to forget that vera started the whole thing and had a lot of brilliant ideas and designs. It just took the wrong turn at some point.

4 Likes

Hi Raf,
So are you running all this on a Vera Plus as hardware? too funny :rofl:
Cheers Rene

Yes, I hadn’t appreciated that either. I thought you ditched all your Veras?

1 Like

I gave away my 2 test units to fellow member @LibraSun . I kept my oldest vera plus which has quite a bit of bad blocks on its storage and turned it into a remote radio source at the central location of the house. It sends the two zwave and zigbee radio serial ports over IP to my NAS which contains all the software. (I had to change the zwave radio and plugged in a uzb dongle in it to get the zway license).
The flash is a bit too fragile for me to give it away and risk screwing somebody’s system, but using it that way makes it write nothing on its flash drive. I also extrooted it. It is a much better (re)use and gave the hardware much more value than with the current mios firmwares.


:crazy_face:

I even wrote a script to modify the vera plus to use it in this fashion.


It literally never reboots and is a workhorse when not running anything mios on it.
Optionally you could even make it a wifi AP as well but I opted not to do that…

1 Like

Thank you for the detailed write-up @rafale77!
So it seems to me in order to use Z-Way you need z-way supported hardware (either UZB sticks or the RazBerry) , it does not sound there is any re-use of the radio on the VeraPlus possible with the Z-Way plugin, even with a license key?
I like to try the RazBerry board, just because it seems to me it has bigger antennas than the UZB (and no license required), do you think it’s possible to export the VeraPlus z-wave network config and import it into the RazBerry (allowing for a seamless transition without changing device ids and device names), or would it require starting from scratch basically?

I did it!
But to do that, you need the UZB! The migration path will be vera -> UZB -> RAZ

The licence key for z-way is stored in the hardware so no it isn’t possible to use the vera’s radio. My script is more useful for people who would want to use home assistant (both zwave-zigbee) or openhab, homeseer, domoticz… for zwave.

Please read my readme draft for which I posted a link a few posts above which explains this. You actually have a couple options I described there and I highly recommended @DesT to do it through the UZB even if he wanted to have the RAZ as the final host to keep the controller id at #1.

Yes thank you very much @rafale77 and @DesT.
I read the full document and also the links to using ser2net. Since my plan so far was to use a Raspberry and RazBerry add on board I Wanted to see if I can skip the UZB purchase. But I can set up the network again, I have about 20 devices or so.

I will NOT recommend for sure, to use zway directly on the raspberry using a SD card. The SD card will die very fast 'cause of the IO from zway.

You can boot from an USB drive instead OR as I did, use a VM for zway and the RaZberry just for the ser2net :slight_smile:

Ah, that is good info, thank you! I had not counted on the IO being a problem.

Have anyone success running it off a USB drive on the PI4,

I have installed buster and used the “usb-boot” tool (https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=196778&hilit=usb+boot.zip). But after installing z-way I can download apps in Z-way or upgrade using the management tools.

2GB sd card, and a 128gb USB SSD. openLuup works perfectly in this setup

Do you mean running zway off of a usb flash drive?
On a Pi, booting from a USB drive is indeed the preferred option, very similar to the vera extroot idea, the sd card or on board flash are too limiting and unreliable.
What error are you getting? What management tool?

I have a RPi 4B 4gb.

A 2GB sd card, for the /boot (Sorry total linux noob), but used the tool “usb-boot” there is a description on the website, on how it works. and in the USB port I have an USB connected SSD drive.
It boots fine, and as I said openLuups installes and works fine.

Z-way “management” -> “firmware update” -> “open updater” gives this error: “192.168.0.xxx refused to connect.”

Trying to download a app gives this error: “Failed to install the app.”

This is discussed on their forum. It is likely a curl version or installation issue. I had this too also on ubuntu. Make sure that curl3 is installed on the OS.


Sorry, it not the fix…

I forgot to mention, that first attempt, was with a running z-way setup, that I moved to SSD, after the moves the errors came. (The RPi image from Z-wave.me)

I have then tried with a plain buster (raspberrypi,org download) setup, did the USB-BOOT, and then installed z-way, and same error

in both tried openLuup works fine

pi@Z-Way:~ $ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Hit:3 https://repo.z-wave.me/z-way/raspbian buster InRelease
Reading package lists… Done
pi@Z-Way:~ $ sudo apt-get install php5-curl
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package php5-curl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘php5-curl’ has no installation candidate
pi@Z-Way:~ $ sudo apt-get install curl libcurl3 php5-curl
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package php5-curl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libcurl3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libcurl4

E: Package ‘libcurl3’ has no installation candidate
E: Package ‘php5-curl’ has no installation candidate

You are missing all the standard repos for debian apt. You only have the zwave.me and raspbian ones. You may need to add them back. That’s why I typically don’t use their images and manually install. Granted it takes a bit more work to install the dependencies but… at least you are in control. I am finding odd though that their image doesn’t even have the needed dependencies.

Can you give min a hint on what repos are missing ? :slight_smile:

But what I find strange, is when taking the image from Z-wame.me, installing openLuup, and both works.
then execution the move to USB SSD, the zway stops working, but openLuup works fine.

Perhaps I need to bring this up in the Z-wave forum… :slight_smile:

Yes it would be best. You made me take out my rPi3 which was running both zway and homeseer… I am running stretch though and have a lot more repos.

Edit: I am upgrading to it buster just for the fun of it.

try sudo apt install php-curl

The problem is that buster now runs curl4 and z-way requires curl3. The devs are aware and will fix it.

Sadly the same error… :frowning: