openLuup & (not) vera

Just looking for an easy way to list all my zwave device name with the ALTID so I can rename my device in zway based on the ALTID from the zwave network :wink:

The thread you linked works fine :wink:

Actually, I liked the idea, so I’ve put it into the openLuup Devices Table…

(available in next release)

1 Like

You need a controller which can do that. The vera could physically do it but the software doesn’t show you the option so support would have to go down one level maybe and send the command classes manually though the serial API.
Otherwise I put out an illustration of z-way. Most openzwave based controllers can do this like domoticz or home assistant. I think I remember Homeseer can do it too. Vera is very far behind in the zwave control area.

Is that screenshot home assistant? I tried HASS but that was a hassle :slight_smile:

No, It is z-way.

Some splitting and merging of threads made the discussion here a bit hard to follow…

To give an update, I think we got the z-way2 bridge to the point where I can pivot my entire 150 node zwave network to z-way and get rid of the luup engine.
I had another luup reload 3 days ago while I was sleeping due to the zwave command queue deadlock caused by a combination of “Got CAN”, “NONCE Get Flood”, “Wait for 20000”, “Wait for 2000”. Yes this unrecoverable failure is rare, but still too frequent to my taste averaging once every 20 days. The recoverable ones are 3-4 times a day out of which maybe one is noticeable every 2 days but none of this is acceptable.
I already validated that I get none of these problems on z-way under the exact same environment and network. So while eZLO is releasing the firmware and hardware which changes everything, including what worked, and without certainty that what didn’t will be any better, I am keeping what worked (and enhanced by openLuup and ALTUI) and replacing what didn’t with minimal efforts. Thank you @akbooer for all the hard work to make this possible. Not forgetting to give gratitude to @amg0 for ALTUI.
No more noodling and bandaging of vera for me…


So, where and what do you run zway? Are you saying you are leaving vera completely?

Edit: I am going to investigate zwave2mqtt based on ozw1.6 for Vera replelacement and hass as the brains.

Since vera support is despitely disappointing me over and over again. It’s always the device that’s the problem. I can’t currently in or exclude anymore…

Yes, I am replacing vera completely. Zway as you can see in the diagram is within the same VM as openluup on my NAS. It bridges openLuup with all my zwave devices which is what my vera was left to do and did not even do well enough.

Why zway not directly to hass but openluup and altui between?

Edit: why not have huge emulator on hass and have no cloud to cloud from Alexa to all your devices?

  1. I am heavily invested in scenes on openluup. It is the master of my system. I also by far prefer lua to yaml.
  2. Hass for all the good things it does, also has some drawbacks. Amongst which the amount of arguably useless breaking changes going through versions obsolescences. While it is moving fast, they are sometimes not very fast at implementing fixes I pushed to them. I even had to maintain my own fork for sometime to keep my system working and had to merge the updates manually. Pretty tedious.
  3. Z-Way is still vastly superior to anything openzwave. Interface and control of the zwave stack at the command class level (meaning there is practically no device which can possibly unsupported), S2 and SmartStart.

Clear. Any tip on how to simply run that zwaystuf on a “virtual machine” with usb pass through and then import the zwave devices from zway in hass?

I can help with everything up the the hass part… You would need a new component to bridge the zway API in written in Python. There is one for hubitat humorously but if you are patient you may get to use the new openzwave interface from fishwaldo. He is making progress but for my use case… I already pretty much have what I need.

Here’s an interesting article on Home Assistant’s new Z-Wave integration (available for testing). This new integration will use OpenZwave running in an independent docker from HA and communicate via MQTT directly.

Here is a very informative thread on the future of ZWave which includes detailed comments from fishwaldo (author of OZW) and the developer of CQC’s new Zwave driver.

The expert comments here echo what @rafale77 has been saying about the evil of frequent polling, nightly heals, etc.

Lastly, SiLab’s Z/IP gateway was discussed as a bridge to existing hubs and alternative to OpenZwave. I wonder if it would be possible for eZLo to push a firmware update to the Zwave chip in the Vera hub to incorporate the Z/IP bridge firmware?

1 Like

I have messed around with the zwave chip firmware on the vera plus and… the only one which works is the bridge version. The static controller does not work on the ZM5304 zwave chip of the vera. Mine has been upgraded to SDK 6.81.06 and is compatible with Z/IP which is a software library silabs offers. Though I won’t be using it much any more, it is more about installing and making use of that library so that the zwave layer can be controller over IP.

I did forget to mention one additional thing… with z-way, I now also have OTA device firmware upgrade capability. :+1: :v:

1 Like

That’s great info to know that you were successful updating the Vera ZWave chip for Z/IP compatibility. I would look forward to the new Linux version of the Vera+ implementing this as well so that the API between it and Home Assistant would be a much improved over the current state.

I’m not invested in Vera scenes or Lua at all. I’m perfectly happy with HA web UI and automation. I still closely follow this forum looking for further Vera stability improvements and would like to continue to use Vera as a ZWave hub. It’s quite stable for me now performing this limited role, but think that a pyzwave > Z/IP interface to it would be a great improvement to extend its life.

EDIT: corrected github link to pyzwave information


An update on status here:
I have not fully migrated yet and am still running both the vera and Z-way on the same network.
What stopped me was, while trying to swap out the nodeID between the vera and z-way, the reinclusion of the vera into the network keeps on failing. So I think I have no other choice than to drop the vera completely and as a result I need to make sure that the z-way bridge can fulfill all the current commands the vera is offering. And it is the case as of this morning.

I discovered while tinkering with Z-way that its API not only enables you to send command class level calls but it also allows for packet level calls! Said more simply, you could literally write any plugin on openluup to support any zwave device even if zway does not support it natively.
As an example, I was able to send zwave packets to my Leviton 4 button scene controllers to take control of their LED displays even though the command class involved is not supported by z-way… and yes this was the last function I was missing and I added this “SetLight” command into the bridge. This capability is extremely powerful for developers.


Reading through this whole thread as a long-time VeraLite/VeraPlus user and discouraged by the lack of real progress on the quality of the firmware I am also trying to evaluate alternatives…
I have HomeAssistant running with the Vera plugin and do most automations through that, but have quite a few Z-Wave devices (no zigbee devices).
@rafale77 I think I have a general idea, but what is your current hardware/software setup to replace Vera?
I was debating a Razberry V2 board with Z-Way and openluup and AltUI running on a RasPi4 (Z-Way seems to be free for Raspberry Pi).
Does that sound Like a capable VeraPlus replacement?
Does the HomeAssistant Vera plugin also work with openluup?
Thanks for any help!

1 Like

Yes the Razberry cap on a rPi includes the z-way licence while the uzb dongle does not, requiring you to purchase an additional license to be able to use z-way. @DesT probably has a closer setup to what you are thinking and will certainly work.
My challenge is to migrate my already very large setup with minimum effort. I was already running openluup within a VM in my NAS (running on 1/8th of a core i7). So I did not purchase any new hardware except for the uzb and a license which I had for a long time. Eventually my setup will be to reuse the vera plus: Plug the uzb into it and use ser2net to send both the uzb zwave serial port and its onboard zigbee port to z-way and home assistant respectively. Both of these are running in the same VM as openluup. The two would then serve as device servers to openluup through bridges. It may sound a bit complicated to setup but really isn’t all that bad once you have lived with vera for some time… For me my expertise in Linux grew exponentially just trying to fix the darn thing. Now I will be reusing the hardware but without the software as I already disabled it.
I think your setup would work just fine and would be a very good replacement.
I am not sure about the home assistant vera plug in. I never used it but I would assume so given that openluup emulates the vera so well.

1 Like

I will take some time this weekend to post something about my new setup that will be “z-wave vera free” :wink: