openLuup: Harmony Hub

Anyone have an issue with the Harmony plugin and the ‘save changes’ button not working? I get a spinning arrow dialog box in AltUI that never goes away and the config changes don’t stick. I am fairly certain I am loading the plugin correctly because if I set all the initial Harmony variables via the startup.lua file, then it is able to connect to my hub just fine, but then I get the same spinning arrow if I try to save things in the Activities tab. I found a variable in the Harmony lua file called onOpenLuup which I tried setting to yes, but no still no dice.

I see that you have already posted an openLuup question on the Harmony Hub child board here,36439.msg277070.html#msg277070.

That was probably the best plan, since @reneboer is the expert. I’d also suggest not to make changes to the code if you don’t know what you’re doing, as this will likely make things worse rather than better.

I have split this post into a separate topic so that there is now a more obvious place to discuss openLuup issues specific to this plugin, but I’d hate to duplicate anything on the Harmony Hub threads, and it’s generally a bad idea to post the same thing in two places.

Sorry for the early cross-posting. I’ve updated the thread in the Harmony Hub sub-section and thought I’d provide the update here as well for those that might be interested. I’ll keep any future discussion on it to strictly the Harmony Hub area.

Hi all,

I am happy to report that this is resolved for the moment. It turns out that the Harmony Hub plugin required that the Docker container I have running openLuup/AltUI be set for networking ‘host’ mode. My next step is to try and figure out why it only works with host mode and ideally configure the container to support it without the host mode setting. I’ll post my findings in the event that I get it sorted out.