No MIOS Marketplace available

After setting up my Vera2 UI4 seems to work just fine except no plugins available. I can add zwave devices OK, but I need to install the plugins for Generic IP cameras and smartphone and don’t see them. Under MIOS Marketplace, there are no plugins. When I click the “+”, I get an error message “ERROR: Unable to connect to server. Please check your internet connection and try again.”. Same thing happens with Vera connected to my D-Link router or directly to my HughesNet internet modem.

Any ideas on what is wrong or some other way to get the plugins I need?

Working from mine!

can you connect to cp.mios over the internet
If not you have a network issue.
Post you network settings and list your equipment and how they are connected.

I left all the settings at their default. I can connect to cp.mios.com, and any other internet site. Except, apparently, the one needed for the mios marketplace.

Network is set up for DHCP. What other settings do you need?

If you can actually connect to vera from the internet and not your local internet I don’t have a solution for you. It could be that your router or broadand modem is blocking your access.
If you can get into the configuration of these devices you may want to open all trafic with no firewall just to see if that works. Then step by step add back any restrictions you might have untill you have the problem again .

Try to see if you can ping download.mios.com or download1.mios.com or go to the advanced tab/firmware tab and see if it tests the connection as ok.

I can ping download.mios.com also download2.mios.com, which is a connection it tries to make under the advanced/firmware tab. But all the connection attempts under the advanced/firmware tab fail.

The problem is that something is blocking Vera.

what is your network configuration?

Configured now as a static IP address on Vera and my D-Link 655 router, subnet 255.255.255.0, gateway 192.186.1.1 (d-link), DNS is same as my d-link router. Tried automatic configuration and DHCP also, with the same results.

@rhenry, in vera’s advanced net config with the static IP try 8.8.8.8 as a name server.

Using 8.8.8.8 does not work either. But you may be on to something. When I click the “Troubleshoot Network” button, all pass except the DNS server. I get an error:
DNSSERVER1:FAIL
DNSSERVER:NONE_VALID

Tried using 8.8.8.8, the address for my d-link router, 192.168.1.1, and also the primary DNS server that works for my router, 67.142.166.10. Nothing seems to work. I also put the IP address for vera outside the router’s DMZ. Still doesn’t work.

BTW, on the Net & WiFi tab, it DOES say “Internet access is ok.”
Anyone know what “Failsafe Tunnels (not recommended)” does? If it won’t hurt vera, I’ll try it, recommended or not.

I used to have the same issue with my 655/Vera and this is what worked for me in earlier versions of the vera firmware. Its something to do with the DNS relay in the Dlink that doesnt play nice with Vera. To this day I still have the DNS set as 8.8.8.8

Not sure if I still need it set that way as I’m about 2 or 3 versions up firmware wise on the 655 and also on UI4. Will try and find out to see if setting back to 655 DNS breaks it.

Might be pointless and maybe you did it already but perhaps reboot your Vera and Router too!

Is this hueghs net a sattelite modem?
If so there could be an issue with that.

It is indeed a satelite modem. That is the only internet connection available at this location. Everything else seems to work just fine through it.

Maybe try to bypass the Dlink temporarily to see if that works? Obviously doesn’t fix your issue but worth a try!

Does your PC need software running in order to connect to the Hueghs network. I knew a few years ago you needed to run a program to connect on each PC.

I took the dlink-655 out entirely and configured vera2 to work as the only gateway. Same results. I could take the PC through it’s router and access the internet, but vera still could not connect back through it.

Put the dlink back in and reconfigured again as static IP on both dlink and vera. Same result. I had someone remote try to log in to it from cp.mios.com. The first attempt it timed out loading data, the second time it did load up but was real slow.

No software needed on the PC, the dlink-655 is the only thing that talks to the HughesNet modem. We have folks come out all the time and access the internet through the dlinks wireless network, also a WPA2 network. I turned off the wireless network on vera thinking maybe there was some conflict, but that did not help either.

Have you tried cp.mios.com from away from your home. Like have a friend of yours log into the VERa. If you can connect truely remote then maybe you have a corrupted firmware.

Are you still getting dns failure.

and then again could be the router sorry for the lack of help

Any ideas and help are greatly appreciated. It still says DNS failure, but I think that is a red herring. Yes, a freind could connect remotely but it was clunky and slow.