New version (1.3.5) of EzloPi is out!

You can download new version from here:

Upgrade Steps

Uninstall the existing ezlopi app.
Run installer ezlpi_x64_v1.3.5.exe

New Features

  • BLE Onboarding added on the firmware
  • Support for ESP32C3 devices

New Added Sensors

  • Water Leak Sensor
  • Analog LDR
  • Digital LDR Switch
  • Touch Sensor

Bug Fixes

  • Fix issue with inverted logic on GPIO switching

Nice! The BLE onboarding is a welcome addition. I have some more ESP32s coming and will try it out.

Just trying this and it seems when I launch EzloPi 1.3.5 and then login to my Ezlo account it doesn’t see the prior two EzloPi devices I created back with 1.3.4

Is there some way to for the app to go find these IDs? I know the controllers still exist as they show up on under controller tab. Somehow 1.3.5 isn’t seeing them.

Hi @curiousB
Appreciate for the question.
If you have the the old installation directory saved, we can retive it from there. If the old installation directory has been deleted while uninstallation we can not retrive the ID from the desktop app. Thank you.

OK but you should probably think of a way to preserve the controller IDs across app upgrade. I deleted the old app per the instructions before loading the new one. For now I guess there aren’t a lot of EzloPi users burning through controller ID numbers. Since the old controller ID still show in my Ezlo account there would seem to be a way for the EzloPi configuration app to retrieve those from the web site once you login successfully.

Anyway I have created a new EzloPi but some issues for sure:

  1. I couldn’t figure out the BLE feature. I thought I’d be able to use my iPhone to set up WiFi. No luck. Might be operator error as there are no instructions or maybe it doesn’t work.

  2. I configured one digital output device and a switch input associated with it. I connected a relay and switch to the ESP32/EzloPi and the local switch toggles the relay so I know the configuration got saved in the ESP32 properly. Unfortunately no devices show for this controller on both the iOS app and . Thats pretty basic functionality and failing straight away. I had more success with 1.3.4

Was 1.3.5 even tested?

OK so the device does show up on the dashboard and is controllable from there but it doesn’t show up in the iOS app or the devices table in the site

In fact the controller doesn’t show up at all on the devices tab and under the controllers tab it shows as unassigned controller.

Tried a door switch input under “other” category. It created a door switch device on my dashboard but I couldn’t control it on the ESP32.

There wasn;t an option to select a pull up or pull down resistor (when you offer this choice on a relay input output setup) so I tried an external pullup. No help.

I then thought maybe this is a touch switch input so I routed it to a touch switch capable GPIO input. Again no help.

I did see the input toggle a once when I was touching the wires to the input but I couldn’t get it to work in any repeatable manner.

So pretty much a bust with 1.3.5 EzloPi

This is only applicable to ESP32 generic boards as it has an internal hall effect sensor. The user has to make sure not to connect any peripherals on GPIO 36 and 39 of ESP32 or configure those GPIOs as hall sensor values are read from these pins. Therefore, providing GPIO to the door sensor is not required. Likewise, a magnet has to be attached to the door in such a way that upon closing the door the magnet stays right over the ESP32 chip which will be detected and give the information.

1 Like

OK I wave a magnet over the ESP32 shell and the switch state toggles. I guess I didn’t read in the release notes or other documentation that a door sensor was implemented using the internal Hall Effect sensor.

That said it seems a very sensitive to proximity and location of the magnet so I am not sure how practical it is. Furthermore alarm system magnet/reed switches are so inexpensive and highly reliable they seem a better option for a door switch closure. A simple digital input with a pull-up resistor and a switch closure to ground.

When I configure a EzloPi for a digital input the config is successfully saved by the EzloPi config app to the ESP32 but the input device never shows in the dashboard at . I checked on the iOS app for the digital input device, but as previously stated, none of the configured devices show up on the iOS app despite some of them showing on the dashboard.

I also tried to create an analog input as well. Same situation as the digital input. It creates on EzloPi esp32 but never appears in dashboard. Tried two browsers and got same result (firefox and chrome).

So lots of bugs to fix I suspect.