Netatmo Weather Station plugin

It worked for me (Vera Edge, 1.7.4799)

1 Like

I’m on the current Beta (4903 on a Plus) - I’ve rebooted and this time it installed perfectly.

I think 7.31 has some real underlying issues as I’ve been having random scenes failing due to the state changes not completing successfully.

Thinking back to my first attempt to install Netatmo today, the install process did not look normal as I never got that pop-up dialogue showing the install process followed by “it’s now safe to exit this screen”.

Thanks for the fix, after updating to the latest the reoccuring downloqd issue is gone.

Thanks for this Great plugin.

Any way i can change the frequency of update? I know the netatmo sever is updated every 5 mins but in the app i am updating only every 10 mins. When i change in the parent device’s variable page it defaults back to 10.

Also the SensorRain value is always zero but SensorSunRain1 works and has value here. Just thinking loud if the value is ZERO because it done not have 0.000 (three decimals) store value.

its super cool to have it control my awnings with wind speeds, rain and temperature.

Quoating the Netatmo API documentation:

" Keep in mind that data are measured every 5 minutes by the modules and sent to the servers every 10 minutes ."

https://dev.netatmo.com/apidocumentation/weather

1 Like

Thanks for your reply. my sincere apologies for double posting this question under this thread and starting a new thread. Posting a link to the new thread question and answer here to consolidate the answer - both answers are exactly the same.

1 Like

I’m not sure if this was an App update or just because my Netatmo lost power for an hour last night, but all my Netatmo child devices just lost their id’s and Room setting and all re-spawned with new ID’s and no Room breaking all my reactor sensors that relied on them. :frowning:

Anyone else have this issue?

PS, @akbooer any chance you could update the Plugin logic to prevent existing devices from being replaced like this?

1 Like

Cheers, I didnt realise that the data was in the main device. :nerd_face:

This has been asked before and many months ago, to no response

The latest update means it’s no longer an issue.

1 Like

Just update via the app or manual update?

Indeed, see:

So this…

… is incorrect.

Just use the Plugins page to update to the latest development version.

My mistake I must of missed this communication , apology. I don’t see any option to do this from the Vera plugin page? Or perhaps the below is already the patched version?

No, the latest is 20.511, available for manual install from GitHub or the AltAppStore.

I’ve generally given up on the MiOS App Store since it’s so difficult (yes, really) to update files there, but I will give it a go.

I have attempted to update using altui and manually by got hub then rebooted but still showing old version

Not sure how you tried to update, but the only file which does need changing is the L_Netatmo.lua file.

IIRC, you need just to upload this using the Vera Luup files page and restart.

I have uploaded the one file but still shows older version

OK, I’ll see about updating the MiOS App Store.

1 Like

The new version (v20.511) is awaiting approval by Vera.

2 Likes

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules