My Z-wave network is slow, unstable and unreliable. Solution? (39 devices)

I have a Vera Plus, with 39 z-wave devices (~10 of them are battery powered). My z-wave network is sometimes very slow, and i get a lot of errors, lights that wont turn on, devices failes to be polled and so on.

I have talked to support, and they have tried different things but i still have a expensive z-wave network that does not work as expected.

I think all that’s left for me to do is a factory reset on the Vera, and factory reset all the devices and try to include them again and hope that it will be better.

Thats a lot of work tho, cus most of my devices is in wall wired devices.

And to be honest, if im going to do all that work, is Vera still worth it or should i get another controller instead?

If i choose to stick with the Vera, is there a potential problem to do all of this with my Vera that is running the latest firmware? I read of all the people having problems after latest upgrade but mine seems to work still.

Please guys, help me out how to fixt my slow unstable z-wave network!!

Regards Jonas

1 Like

There’s a great thread on this called Z-wave network explained, or something similar. Explains some steps you can take. The pros will be along shortly!

C

1 Like

It’s a long answer but your answer is in there. I am 100% sure. I am surprised support couldn’t help you. Maybe they should get some training. with 10 battery operated devices, and with their wakeup interval set at the default settings, you are saturating your zwave bandwidth >33% of the time. There isn’t enough time available for useful data to be transmitted. @Catman beat me to the answer this time. :slight_smile:

2 Likes

Thank you, i have read the thread multiple times and made some changes according, but i still struggle with my bad network. I doesn’t seem to get it working. And now it feels like i have made so much changes i no longer know what i have done and not done :see_no_evil:

Seems the only way left is to make a clean install but its soooo much job

Ok let’s take it one step at a time.

  1. What firmware version are you running? If on 7.0.29 or below, most of the tweaks will not work. All you can do is to extend the wakeup intervals of your battery powered devices.
  2. What is the wake up interval of your battery powered devices?

The clean install/reboot is just a way to say “I have no idea what is going on so let’s try to start from scratch”. There is no guarantee that this will do anything and from your description, I am fairly sure that it won’t help.

Just! :smiley:
C

I’m on 7.0.30
I have changed the wake up to something like you suggested. Biggest issue after the speed problem, is that i get ALOT of Cannot detect devices, but still they work.

Yeah the Cannot detect devices are due to either failed polls (for AC powered devices) or devices waking up but the network was too busy to recognize them (battery powered). Both should get fixed after some time after eliminating the wake up nnu and the nightly heal along with also extending the interval between polling.

Its almost only AC powered devices that fails. And i have set them on never poll but still they get the message. Is it possible to look at the logs and see if there is something spamming the network?

Do the message come and go? How did you set them to never poll? Did new messages pop up once you set them to not poll. For the vera 10 battery operated devices is a lot at default settings unless you disable wakeup nnu.

Changed the poll setting to 0 on the Unit/settings tab.

Yes the message come and go, but is mostly marked as “cant detect device”

ok then I would need to look at the logs. There aren’t 20 ways the messages come. They are set whenever a command either user or poll fails. If they are not polling anymore then it is a command failing. Just in case, what do you see for the pollsettings variable under the device’s advanced/variable menu?

The PollSettings says 0.

And for now im also unable to include devices, gives me fail multiple times. I guess that have to do with crowded network?

Yes it could be. The only other thing I can think of is that you have a loud device which was not configured properly. In that case I would have to see the logs. But I suppose support should have already done that. What did they tell you?

They found one device that was spamming the network, but they didn’t make it better (if im not remembering wrong they didn’t manage to configure it. So that device went to the garbage can

Interesting. I suppose the problem devices are all AC powered?
If that’s the case I would try to either power cycle them or turn them off and leave them off one at a time and observe the behavior for a few hours. This is a little brute force troubleshooting but without seeing your logs, I don’t quite how else to do it.

How do i get the logs out of the vera?

i have a similar issue on my network and was told by support that the root cause is because i did a restore from an old vera lite to my new vera plus. their recommendation was to exclude everything and start from scratch. issue with that is that i have a bunch of in-wall devices so it would be a giant pain to go through it. if i do exclude everything i most likely will go to another platform.

@sebby, I am not a fan of that answer either but I would like to know why they think that way. I have heard that in the past and suspect it is due to the use of vera zwave routing which disappears on UI7 or it is the switch from zwave 300 to zwave 500 but that I wouldn’t know why either since the dongle data is supposed to be compatible. Oh well…

Now i have finally made some progress! There were a smart plug (Nodon MSP-3-1-x1) that spammed my network. Disconnected all 3 of them and bam! My network is super fast and no more Cant detect device!!!

Strange thing tho, how can a factory calibrated plug be doing this? Now i have 3 Nodon plugs that cant be used :confused:

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules