My new Vera 3 is bricked!

This is my first experince with mi casa verde products. I decided to wait a couple months for this product to come out. It wanted to upgrade the firmware when I first connected and that seemed to go ok - it worked fine after. Then I went around the house to add my z-wave devices, and came back to connect up. The power light just flashed red/green and the factory reset thing makes no difference. Any ideas?

Hit the factory reset button twice very quickly.

I tried hitting the reset button twice many times before posting. If I do that right after after powering up, the light flashes very fast, but it stays in that mode. There is a “help” button. Not sure what that does, but it didn’t help me. I also sent a support ticket, so I’ll see if they respond. If they don’t today, I’ll be returning it and may get the Vera2. My guess is that Vera2 has more bugs worked out of it.

I would try my best to figure out what is wrong with the Vera 3. If you are in the US, you’ll get a faster response by calling them. Hopefully the solution is an easy fix. With any hardware, there are DOA’s. Try and not too give up too soon.

  • Garrett

ditto, I would stick with the Vera 3 even though unfortunately it may take a couple weeks to work the major bugs out

Did the power light start flashing after you connected Vera to the mains?

I’m not sure what this means “after you connected Vera to the mains”. Here is the sequence: 1) I disconnected the working Vera3 from power and internal network and started with the external battery. 2) Went to my 3 z-ware door locks and paired according to the instructions, saving after each paring. 3) With the battery still connected, I plugged the network cable from the router into the WAN port. This is a deviation to the instructions since they say to reconnect it as it was originally. 4) I then disconnected the external battery and reconnected to the A/C adapter, leaving the network cable connected. 5) Flashing power light issue.

BTW-This sounds like a great active user community. You guys give me hope, so I will try to be patient and get this thing resolved with the Vera3. At least for some reasonable amount of time.

Are you sure you didn’t connected Vera3 to a wrong power adapter? If should write on it 12V 1A DC
The power led blinks during the system start up, and should turn green solid after all init scripts have finished.
If it doesn’t get solid it means it didn’t finished the boot process because it hangs somewhere.
If you’re more techie you can open the Vera3 unit and connect a serial cable (57600 8N1) to it and watch the boot process or
you could send it to as back and we’ll fix it.

Yes, it is connected to the correct 12 VDC 1A power supply.

Mine Verde3 did the same thing today. Powered it up and did upgrade. put in doors and light switch and reconnected it back to the internet, plug in power and notthing but red blinking light.

@ssenneff, Slipfee

Can you send an e-mail at with a phone number you can be contacted on?

Exact same thing just happened to me! Paired a few switches and light control. Now its just flashing red and green. Tried playing with the reset button all day.
Perfect timing too… Family is staying this weekend. Not happy at all…

Sent from my SPH-D710 using Tapatalk

Same problem here. Just got the Vera 3 2 days ago. I am starting with a small system. 3 devices. I initially paired and found 1 of the three had problem with communication. I updated to the latest firmware and the problem remained. After trying to repair the network a couple times, I gave up and decided to reset the network. All seem fine on the reset so I started to re-pair the switches again starting with the one I had problems with. I brought the Vera 3 to it and it seemed to pair fine. I shut down the Vera 3 and brought it back to reconnect to main power and ethernet. Never came back up properly. Just a flashing green and orange power light. No amount of resetting is helping. I put in some email requests for help and will call after Christmas but it’s a bit disappointing compared to my experience with my previous home automation (Indigo on the Macintosh. Unfortunately, it doesn’t support Z-Wave yet and I wanted to switch).

I’m assuming these are just growing pains for a new product. Just a bit frustrating though there isn’t an easy way to reset to factory settings.

Simdude, when a device is hard to pair make sure to try excluding first even if its never been included, also check if the device has its own reset procedure

I can confirm that I used the same power supply the Vera was always plugged into so there is no possibility of this issue… I have a call, and email into the MCV team as of yesterday and will report back once I receive a response.

+1 to bricked vera 3 message thread (if anyone is keeping track). I have exactly the same symptoms as described above. Green / Orange alternating flashing on the power LED. Unplugging & replugging the power or pressing reset button twice does not change the behavior. AC adapter is the only thing connected to vera right now.

I received my unit about 10-days ago. Upgraded the firmware to 1.5.215-en (I think) and I was able to get a trane thermostat and schlage door lock paired by using the battery pack and carry vera with my laptop connected to its wifi. That worked for a few days as expected.

Today, I paired two new GE outlets (again using battery pack) and that seemed to work fine. I created some scenes and schedules and that also seemed to work fine.

When I removed the battery pack and attempted to switch back to the AC adapter, it never booted again.

Out of interest, how long after adding the modules did you wait before switching back to the A/C adapter? I’m wondering if it was still writing some configuration perhaps when it got powered off?

I’ve never trusted the power packs and either try to do it will full power include, and if that doesn’t work then I plug in my Vera near to the module I’m trying to include.

I’ve just finished migrating everything over from my V2 to the my V3 (decided to do a clean install, rather than copy) and added 50 or so nodes without a problem. (yet :slight_smile: )

I probably waited 5-minutes or more after adding the modules before powering it off. Now that I think about it, I also installed an app while on battery power. It was the smartphone app, but it was at least a few minutes before I tried the switch back to AC.

At any rate, pulling the power during download or adding devices shouldn’t put the device into a bricked state?? The only thing I would expect to brick a unit would be if I powered off during a firmware upgrade.

Got some great help today from George at Micasverde. I followed these instructions and was able to reset the Vera 3. Very easy as long as you don’t mind typing a couple entries in a terminal. Here there are:

  1. Connect your computer directly into the LAN1 port on the Vera3 unit
  2. Plug the power adapter in Vera and when the red light starts blinking, press and release the reset button
  3. Put a static IP on your computer ( and the gateway (subnet mask will always default to - so leave it like that)
  4. Open a command prompt and telnet into the unit: telnet
    Then run these commands:

mtd erase rootfs_data
flash_eraseall -j /dev/mtd7
echo b > /proc/sysrq-trigger

  1. Now the Vera unit should reboot and you should see it booting up. It might take a couple of seconds minutes, first the LED should be solid red, then green, red and after that it should boot up.
  2. Change your IP address back on automatically or and gateway
  3. Check that the Dashboard loads on after all the LEDs are on and solid green

I logged in to post the exact same solution that George gave me via Email. Will give it a run tonight.
I’m thinking i’ll start from scratch as well now.