More Vera Issues - stability and UI funkiness

Argh…the past few months have been a pain - I recently had the “server not allowed” issue with a firmware upgrade, and support was finally able after a few tries to upgrade the firmware and restore my app store (which was also broken).

2 days ago all of my z-wave devices completely disappeared, and the unit was prompting for another firmware update. I downloaded several backups (just in case) and tried the f/w update - “server not allowed” error yet again! I then restored a backup from a known good date and clicked the ‘restore z-wave network’ box. Still can’t see any z-wave devices in the UI; if I use an app (imperihome) or AltUI, I can see the zwave devices, and most functionality is back, but my scenes are somewhat messed up (not all running), and I can’t recreate any of them using the UI since it can’t ‘see’ the devices.

Ugh - I’m about to submit another support ticket, but this has been a frustrating couple of months…

This recent firmware update is the first one that hasn’t gone well for me. I had it update while at work and it never came back. Had to go home and power cycle it. It eventually came back but as a new device so i had to restore from backup. Weird… I’ve never had any of those things happen before. I managed to get it back up from my backup and didn’t have to engage support but it doesn’t leave me too thrilled.

I had a similar experience, except I had to do a hard reset, actually plug it into the router to reset the Wi-Fi, then restore the backup. Overnight, it stopped working and had to be booted again. All is well the last 2 days.

I’ve contacted support to see what they can do…if that fails, this may be my next course…

At least one of my issues: a door sensor flicker during nightly heal appears to be gone after I reloaded the firmware.
I am more and more suspecting the data integrity on the vera. It seems to be prone to corruption…

I ended up going for it -

I was able to resolve the issue by doing the following:

  • Downloading a copy of the backup from 2/17 that was known good
  • Performing a factory reset on the Vera controller
  • Re-associating my controller with my Vera account
  • Resetting the Z-Wave network and chip on the controller
  • Updating to the newest firmware, performing a factory wipe (again)
  • Restoring backup ? ensuring that I check to restore z-wave network as well
  • Rebooting Vera one final time

Everything seems to be back up and running at the moment?my KIRA and PLEGG settings all seem to have made it through the restore.

And almost exactly a week later, it FUBARed itself again. Woke up to a completely corrupted system - the UI would begin to load, but with only a spinning icon and some errors in the real-time log area at the top of the screen. Errors were all about not being able to load the device definitions - first one was the Z-Wave network, etc. No way to do a reset via UI, so I had to do a hardware factory reset using the physical button.

Got it back up, restored my system/network and it worked…for all of about 10 minutes, then the Z-wave network became non-responsive. Wash rinse repeat

Got it back up, restored my system/network and it worked…this time for all of about 1 Z-wave event. Wash rinse repeat.

Got it back up, and it seems to be staying up…but I have very low confidence. I think my Vera Edge hardware is effed - this is the second time lately, and the third major event where spontaneously I have had full system failure and corruption of the entire OS/system.

I’m leaving town for a week and don’t want to leave my wife with a ‘dumb house’ - so I 1-day-shipped a replacement from Amazon and will swap over to that unit. Hopefully its as simple as restoring from my latest ‘working’ backup…

After that, I may be looking for a more stable platform…

For some reason today, my unit lost wi-fi. Rebooted it at lunchtime, no change. Tonight, I did a factory reset, restored from backup, and all is well - for now. I suspect it was my router, in hindsight, I should have rebooted it first.

I think Vera Restarts when you regain internet connectivity after it has been disconnected for a short period of time (long enough that connections drop)

I think my issue was the wi-fi portion of my router. I could not see my SSID although my neighbor’s SSID was showing up.