Missed Alerts + Disappearing Pictures

Strange Vera Alerts Behavior

  1. Missing Alerts - Random missed alerts (i.e. driveway sensor trip sends picture) This morning we received no vera picture or alert but 5 min before it reported other activity and 25 min later it reports other activity as it should.

  2. Disappearing Alerts - We have had strange issues with alerts disappearing. Driveway alert pictures are there, click them, view them… then later in the day the alert and pic are no longer in vera alerts they just vanish.

Very Strange

My next question is… I have gone through a few phones that had to be sent back to manufacturer. I factory reset each device before sending it back. If after the device is refurbished and sent back to a customer who also uses vera alerts… will they start to receive my alerts since the device was once registered?

Thanks
Dan

After analyzing many logs from others that have reported missing alerts … it has usually been traced back to Vera restarting at the time of the event.

You need to scan your Vera log file. It can take a couple of minutes for Vera to die a slow death where things are not working before it actually restarts.
So you need to verify that there were NO restarts within a couple minutes AFTER the missing event.

You can turn on Vera Alerts debug info using the Settings tab. This will add more details about Vera Alerts activity.

Picture related problems cab be caused because of disk space (free memory). Do you have a USB memory stick installed. Pictures are stored in the same location as the log file.

The alerts can also disappear from the Vera Alerts memory if you have a Maximum # of message setting in Vera Alerts.
Actually the pictures will not be deleted from the phone … If you search around you will find them. (SDCard/Pictures/VeraAlerts)

Ok I will double check the usb and the log files. It isn’t just with the pictures its with other alerts too. About 15 min after the first missed event. The next event was “motion normal” then 7 minutes later another “motion normal” there should have been a "motion detected in between the two.

I will get the logs later and update you. What do I do take the usb out and put on a computer to get the files (vera log, and vera alerts log)?

Thanks

You do not remove the USB.
After inserting a USB you need to change Vera Setup → Logs

To View the log file:
http://Your.Vera.IP.Address/cgi-bin/cmh/log.sh?Device=LuaUPnP

Ok well after reading that I checked and saw USB not mounted… hmmm i figured one of my kids pulled it out but upon getting home it was there. So I pulled it our to throw it on the computer and see if there are any logs or pictures… it was completely blank. This thing has been in there for a year and I never set it up???

So I re-formatted the 16gb drive in fat. Plugged it in. Checked store logs on usb. Clicked ok.

Waited, Refreshed:

Errors log:
2015-02-08_19:44:00 CHECKDISK: Starting to check device: /dev/sda1 with: /usr/sbin/e2fsck
2015-02-08_19:44:01 (/dev/sda1) : Successfully checked

Look good?

How is it in the past it would seem I could have unlimited pics? Is it possible it was working but then stopped?
Will the pictures be stored on the drive automatically at this point?

Also pulled up that url you gave me… every time I try to browse it keeps scrolling to the bottom. But I did see a failed vera alerts attempt.

01 02/08/15 19:35:35.791 RAServerSync::SendAlert retries 1 failed https://cms2.mios.com/alert?PK_AccessPoint=ABUNCHOFCHARACHTER_Key=ABUNCHOFCHARACHTERS=9&LocalDate=2015-02-08%2019:35:20&LocalTimestamp=ABUNCHOFCHARACHTER&AlertType=3&SourceType=3&Argument=14&Format=&Code=Tripped&Value=0&Description=MOTION%20NORMAL&Users=ABUNCHOFCHARACHTER

My next question is… I have gone through a few phones that had to be sent back to manufacturer. I factory reset each device before sending it back. If after the device is refurbished and sent back to a customer who also uses vera alerts… will they start to receive my alerts since the device was once registered?

Thanks
Dan

That is not a Vera Alert error … that’s a MCV error.
The USB is not formatted for FAT … it’s formatted as a UNIX disk. It was probably reformatted.
You can NOT read it on Windows.
You will not have a problem because your phone might be reused.

Ok Thanks!

Ok update! The pictures seems to be resolved with the install of the usb flash drive. However the missing alerts happened again. At 2:30 yesterday phone 1 received its last transmission while phone 2 continued to get notification.

Any ideas?

For me to assist you will need to provide:

  1. Output from Vera Alerts “Report” command
  2. Output from Vera’s log file (see info above to access the log)
    Make sure you turn on Debug in the settings tab.
  3. Do you call Vera Alerts in LUA or in the Advanced Tab of a scene of PLEG ?