Luup reloading continuously

hey i just got home this morning and i notice my vera reloading after 2 days uptime, then it just kept reloading, and reloading and it still is

might want to look at the logs… There can be many sources of it. If it is a vera plus and if you have zigbee devices… I once upon a time had one of my centralite zigbee plugs go weird. I just had to unplug it and plug it back.

i was abole to get a backup loaded that was created this mornign @ 1:35AM lets see if it works. Ps i couldnt even get to the logs bc it was reloading that fast

You can get the logs by SSH… It is independent of the luup engine. Unless your vera is rebooting and not just reloading the engine.
Look into power cycling your zigbee devices if your backup does not work. I tried the backup too when it happened. At the time I was messing with zigbee configurations and likely some errant zigbee packet must have hit that one device which did not like it. (572.6 KB)

i was able to pull this

this thing is going crazy

yup its bricked

are you able to SSH into the unit. As long as you are, it is salvageable.

i posted the logs earlier … i was able to get a backup downloaded from the server, i now get only the please wait page but in gonna hard reset it and see if i can revive it that way

Went over the logs, and am not sure exactly. It seems to decide to restart about the time the AutoVirtualThermostat is trying to load. Have you tried taking it off the network and seeing if it loads OK without its internet connection?

50 07/25/19 11:33:49.226 luup_log:691: AutoVirtualThermostat: Running! <0x76fc6520>
03 07/25/19 11:33:49.227 JobHandler_LuaUPnP::m_bReloadCriticalOnly_set now 1 <0x76fc6520>

it just stopped loading now, literally the first 3 lights on the unit and thats it, ssh no longer works

Looking at the logs as well. They seem to all be watchdog (code 137) or self inflicted reloads (code 0). It all occurs during loading of plugins. Reactor/opensprinkler

that is awfully strange it was literally up for 2 days without problems

@wilme2 the system runs for several seconds after that, and if you look through the whole log file, you can see that the restarts happen at various times. Reactor is logging messages showing it is waiting for Z-Wave to come ready, so it’s taking a long time for the Z-wave network to initialize, apparently, and in some cases, it never does. Two of the stops in the log have this message:

01 07/25/19 11:33:55.389 ZWave::SetRFReceiveMode failed (nil) <0x767c6520>

Seems a bit dire. There’s also:

02	07/25/19 11:35:19.628	OL: (0x19b4960) (>24834) SendReceiveMutex ../ZWave/ZWJob_GenericSendFrame.cpp l:105 time: 11:35:18a (1 s) thread: 0x771d7320 Rel: Y Got: Y <0x6a81f520>
02	07/25/19 11:35:19.628	finished check for exceptions <0x6a81f520>
02	07/25/19 11:35:19.628	OL: (0x19b491c) (>24837) SendMutex ../ZWave/ZWaveSerial.cpp l:510 time: 11:35:18a (1 s) thread: 0x771d7320 Rel: N Got: Y <0x6a81f520>
02	07/25/19 11:35:19.628	finished check for exceptions <0x6a81f520>
02	07/25/19 11:35:19.629	OL: (0x19b4960) (>24838) SendReceiveMutex ../ZWave/ZWaveSerial.cpp l:511 time: 7:00:00p (1564068919 s) thread: 0x771d7320 Rel: Y Got: Y <0x6a81f520>

And a lot of the familiar:

01	07/25/19 11:38:32.147	got CAN <0x75d08520>
02	07/25/19 11:38:32.148	ZWaveSerial::Send m_iFrameID 0 got a CAN -- Dongle is in a bad state.  Wait 1 second before continuing to let it try to recover. <0x76108520>

A lot of these are coming in series during the initialization of Z-Wave, right at the start. It’s always hard to know what’s going on under the hood with Vera, we just don’t know, but that doesn’t seem good.

01 07/25/19 11:38:34.573 ZWaveJobHandler::ConnectionIsValid failed first time -627861324 <0x76108520>

Hmmm. I don’t think I’ve ever seen that one before.

My first stop would be a hard reset of the box: power off for 60 seconds, then back on. I would approach this carefully by using ssh to get in and typing poweroff and then watching for all of the system lights to go out (except power). As soon as they go dark, pull the plug (or the system will restart on its own–not what you want). Then wait a minute. Then re-power and see what happens.

yeah sorry guys, the battery in my mouse died and just got frustrated and wen to cool out for a bit, but it still hasn’t come back. all the interfaces initialize but Ethernet / network interface doesn’t come back, but I am at work now

You likely had some hardware failure… I don’t think the zwave chip alone can take down your SSH. Its use is a program coming up after the OS is loaded. It could be anything on that board… CPU, network chip, Flash, DRAM…

yeah when i get home ill try to get it back up

got it back up, the did a factory resto not usb loggin wont come on