"Lua startup failure"

Hello I’ve been looking around like crazy for a solution but nothing has worked. I’ve deleted my PLEG device, created a new and imported all information. The import worked but still says “lua startup failure” on reload of pleg.

I have gotten the logs for my startup of PLEG (in attachments). Can anyone see what’s wrong? Im desperate :smiley:


Nvm I reinstalled both PLEG and PLC and now it’s working!!! My life is BACK!!! :slight_smile:

I had the same problem. Thanks to your tip I tried reinstalling only PLC and that worked!

Exact same problem for me. All my PLEG programs stopped working. I uninstalled and reinstalled the core logic and all is working fine again.

Same problem for me – reinstalled the Program Logic Core app and my PLEG no longer had the Lua error message. Was this caused by a Vera firmware update? last I checked my PLEG had no noticeable problems before I updated.

Hi Day two of Vera.

I have installed an App, Smart Virtual thermostat.

And the device it created is showing an error of ‘Lua Startup Failure’

Is this a problem /issue?

I have installed and uninstalled the App the problem re-occurs.

“Lua Startup Failure.Can’t Detect Device”

I have seen this on other Apps I installed and subsequently deleted because I could not get them to work.


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules