Lost all z-wave functionality

I have Vera 2 with firmware 1.1.1362.
After months of trouble free operation I got the dreadful no z-wave dongle error. >:(
After opening a support ticket with Micasaverde, my z-wave dongle was restored (I have no idea what they did), and the error message disappeared.
However, I still cannot control any of my z-wave devices. I have tried to exclude or re-include my existing devices, but none of them seem to be recognized by vera.
I tried to restore an earlier backup, but that didn’t seem to help either.
I keep getting transmit failed with code: 2 errors.

Any ideas how to debug? what can I do to regain control of my system?

When restoring an earlier backup (one that you know worked) did you also check the box to restore z-wave dongle as well?

  • Garrett

No I didn’t check: Restore Dongle Firmware (takes up to 2 hours and is not recommended).
I will try that and report.

It should only take a few minutes to restore, but that is key to getting your zwave network back.

  • Garrett

I have tried restoring from 3 different backups (including dongle restore). They appear to restore fine , but I still can’t control any of my z-wave devices. Serial devices do work find.
All z-wave modules fail with: Transmit failed with code: 2

Any suggestions?

If you did a complete restore the paired devices can be out of sync with the previous pairing details. Try unpairing and the adding the device again. This is what I had to do.

My vera still cannot communicate with any of my devices.
I cannot include / exclude any device.
Keep getting transmit failed with code 1 or 2

Problem finally solved after going through the steps outlined here: http://forum.micasaverde.com/index.php/topic,8976.msg58978.html#msg58978

  1. Copy the url (link) of the build you want to install. *** http://download.mios.com/firmware/wl500gP_Luup_ui4-1.1.1245-1.squashfs ***
  2. Find the last good backup of your system and have it available.
  3. Go to the firmware tab of your UI and copy the link for the desired build into the box: URL for MiOS custom firmware and hit “UPGRADE”.
  4. Select “FACTORY DEFAULTS” when prompted in the process.
  5. Wait for Vera to install the selected firmware.
  6. Restore the selected backup in the backup section of your UI. Provide the path to the backup by clicking “Select file” en then hit the “RESTORE” button

Worked for me although I never upgraded to UI5.
I am happy to have my vera2 working again :slight_smile:


Then update the firmware using micasaverde.com/vera2 and not cp.mios/firmware.

The irony of this is it just happened to me with firmware 1.1.1362 as well. No reason, just lost it. Restore…