Leviton VRCS4

I’m considering installing the Leviton VRCS4, but from the instruction manual I’m not sure it will do what I want it to do.

It’s a 4 button scene controller. Can I install it in place of a switch to control that switch PLUS 3 scenes? Are the scenes programmed on Vera’s UI or do I program on the unit itself?

Thanks for any insight you might be able to share.

Thats a good question.

It will control one load directly and 3 scenes and I know the instructions say you need the hand held controller to program it but it can be configured through Vera using UI4. There is a Vizia plugin on the Mios Marketplace “Leviton Vizia RF+ Emulator” which I believe is used for the programming but have yet to read what it does.
I have this switch but have yet to connect it so look forward to seeing some instructions being posted.


The VRCS4 does control the switch, however playing with this device reveals that you may be able to set more scenes than 3. You are able to set a scene with both the “on” and “off” status’ of the buttons so in theory you could set one scene to run when the button is “on” and another scene to run when it is set to “off”. To get the VRCS4 up and running be sure you read the wiki on it. You have to put the VRCS4 in program mode before you ever set the Vera to include mode.

Just to clarify - the VRCS4-1LX is a scene controller only and does not control a local load. The VRCS4-MRX does control a load, but as a switch and not as a dimmer. The Leviton RF plugin works with these devices very erratically on UI4 version .1062.

I have a couple of these Leviton switches.

You program the switches through Vera. There was a delay in getting the programming information downloaded from Vera to the switches, so be patient.

The Leviton switches can only directly control other leviton devices (the documentation says only “Scene aware” devices). The non leviton devices are switched after Vera gets the command and reprocesses it. In other words, the Leviton devices react immediately, the non Leviton devices will have a slight pause before reacting.


Are you saying that you have yours working without any issues? I have two and they both don’t work with UI4. Press button 1 and nothing happens, button 2 activates scenes from button 1 and so on… The off function does not work on any scene. I haven’t tried the Leviton Vizia RF+ Emulator, is this necessary in UI4? I would love to get these controllers working again.

Seems we are back at square one. Confusion.
I just pulled up the instructions for the 1LX which now makes them look a little misleading at first glance
“ON/OFF LED for remote load status” If it does not control a load it should not reference LOAD.
It should read -“ON/OFF LED for scene status”
Now I will have to double check which model I have. ???


I have the VRCS4-MRX and I can confirm that it is working fine for me in UI4 (1.1.1047). I first configured this controller on UI2, but after upgrading to UI4 I only had to re-assign the scene control to the buttons. Otherwise the only difference that I have seen between UI2 and UI4 as it relates to these is that with UI4 I get better LED feedback of scene status on the controller.

Mine is setup to control 4 different scenes, one for each button. Two of the four scenes include control of the local load (which vera sees as a separate switch), so using either of those buttons toggles the local load as well. It’s not perfect, but it works pretty well. Aside from the local load component, all other switches controlled by these scenes are non leviton, so there is definitely some delay. Unfortunately the delay varies by switch, so when I hit the “all off” scene button for example, my livingroom lights start dimming and switching off in their own time. It can take up to 5 seconds for all of the lights to get the signal, but I’ve found that I actually don’t mind this… it’s kind of amusing if you have a sense of humor about it.

I don’t recall the exact process for adding the device into Vera now, but I know I an others have discussed it at length in these forums. As far as I can remember it involves adding the controller first (add one z-wave device in full power mode) and then hold down buttons 1+3 to add the controller. then repeat the process using buttons 2+4 for the local load. Once you have them both added, treat the local load as if it were a totally separate Leviton device. You can assign it to scenes, or just assign it directly to one of the 4 buttons via Vera if you choose.

I should also mention that I do have the Vizia+ emulator plugin installed, though I added it after I got the devices working, and it didn’t seem to make any difference. I’ve never been able to figure out what that is for.


I would not say that the Leviton switches are working with no issues, but they are working. I am still on UI2, where I will remain for the forseeable future.

The Leviton switch has the same limitation as the HA07 Controllers - Vera can differentiate the “on” buttons, but cannot differentiate the “off” buttons (in other words, button 1 off is the same as button 2 off to Vera). The off buttons will work for Leviton devices, of course. On non-leviton devices, Vera will run “Scene 0” whenever an off button is pushed.

I solved my off button problem by using Lua code. Essentially, whenever a switch is turned on, I set a Lua variable marking that switch. So when the next Off command comes in, that switch is the one turned off. This is a little kludgy, I admit, but does kind of work.

To tell the truth, I prefer the HA07 or HA09 controllers, since those controllers can directly control most of my devices, and the off buttons will work without Vera being involved (it is just Vera that has the problem differentiating which off button is pushed).

I added the VRCS2-MRZ last night which took about an hour deciphering the instructions. Poorly written in my opinion.
Under the scene section of the scene controller device can you post what the screen shows?
This is the section for the VRCS2-MRZ which shows the ability for 4 scenes as well as controlling the 2 local loads.

Automatically turn on/off the scene indicator lights
Activate the following scenes when the buttons are turned on:
Button #1 - Please select -
Button #2 - Please select -

Activate the following scenes when the buttons are turned off:
Button #1 - Please select -
Button #2 - Please select -



[code]Automatically turn on/off the scene indicator lights (checked)
Activate the following scenes when the buttons are turned on:
Button #1 - LV Lights
Button #2 - Accent Lighting
Button #3 - Dining Scene
Button #4 - All Off

Activate the following scenes when the buttons are turned off:
Button #1 - LV Lights
Button #2 - Accent Lighting
Button #3 - Dining Scene
Button #4 - All Off[/code]

Note that I’m not trying to differentiate scene ON and scene OFF actions. My local load is switched as a part of both LV Lights and Accent Lighting scene, so when either of these buttons are pressed, the load is switched. The only real quirk to this is that while Vera isn’t setup to differentiate between On and Off presses, the local load is directly controlled from the controller so it is. If I press button 2 once, all my accent lights come on (including a sconce in the hallway connected to the local load). If I press it a second time, the sconce turns off but everything else remains on. This works fine for me since the lights controlled in scene 2 are a subset of those in scene 1, so I can raise and lower the light level by using button 1 or 2, then turn everything off by hitting button 4.


Both of my scene controllers are Leviton RZCS4 and they worked fine in UI2 its just when I switched over to UI4 they started to experience all sorts of problems. These controllers are very similar just no direct load switching. For now I use my HA09 as a replacement until a fix is released. I placed a ticket for this many months ago, still waiting for a fix…

Thanks for doing that.
Thats really neat, I guess you could have 8 different scenes!! It didnt even occur to me last night with the VRCS2 to use the off state to turn something on or vice versa.
I verified my VRCS4 device and I have the MRX. Now i’m excited about getting it hooked up, not looking forward to the inclusion process though…


Yesterday I installed and setup a Leviton Vizia rf+ VRCS4-MR. Once added it shows up in my dashboard as 2 separate devices, one a switch and one a 4 button controller. However, for some reason the top button of the controller does not control the light it is wired to. I suspect it has something to do with the way it was added to the network. I assigned scenes to all four buttons in both the on and off modes. Initially, the off modes did not work for a few minutes after setting them up in mios. However after a short delay, they seem to work fine (be patient). The only problem is I had to assign a on/off scene to the top button to control the light wired to the VRCS4. It works but not instantly the way a switch should. I am tempted to exclude the controller and then re add it to see if I can get the switch to work but after ready about some of the problems others are having with these controllers I very reluctant to do this. Does anyone know if there is a way to reprogram just the top button to control the light?

Same issue with mine…
I have to double tap the top button to get the load to turn On or Off, not always but most of the time.


I have issues with my scene controllers so I took a look at this plugin. I haven’t installed it, but from the description, it’s unlikely to help anybody here. Leviton sells a serial (RS-232) to Z-Wave adapter (VRC0P-1LW or the older RZC0P-1LW, see http://www.smarthomeusa.com/ShopByManufacturer/Leviton/Item/VRC0P-1LW). This plugin appears to let Vera pretend to be one of these adapters.

The RZC0P-1LW adapter was popular a few years ago and at the time was the best way to issue Z-Wave commands from a computer. Part of it’s popularity was that it worked, was modestly priced and programming documentation was available without a license (http://communities.leviton.com/docs/DOC-2392). This led to it’s support in some open source software packages. Lately, I’m seeing more interest in USB interfaces (typically the Aeon) and software like openzwave.

The VRCOP-1LW is the controller of choice for the ELK or HAI Controllers if one is going to utilize Z-Wave with those systems. It is a secondary controller. The issue with it at this point is it not running the 5.02 firmware so it is not capable of AES128 encryption. The issue with the VRCS4-MRX sounds more like a software issue than hardware as I know it is working correctly with other software.