Leviton VRCS2 2 button load and scene controller - How I got it to work in UI5

I recently purchased the Leviton VRCS2 2-button remote and struggled mightily to get it to work. I finally found all the pieces, but I had to do multiple searches and not everything was in one place. I thought it might help someone else if I put it all in one post.

First, this is a complicated device that is very flexible. It will take a little work to get it set up properly. Secondly, I was NOT able to get it to pair using full-power pairing nor using the VeraLite running on batteries. Get a long network cable and extension cord, and put a TV tray in front of the switch with your laptop and vera. I promise it will save you many hours of trying to get it set up. After I put vera on a tray in front of the switch, it configured first time, no issues.

Second, this device is a combination Scene controller and two appliance module switches. When you join the zwave network, it will no longer associate the buttons with the switches. They are NOT internally hard wired, but more like a remote control and two appliance modules in a small package. Unless you create a scene to map the buttons to the loads, the buttons will not control the loads after you pair with Vera. That may sound dumb at first, but it’s actually pretty cool. The wiring diagram wasn’t accurate and I wired it backwards, so my loads were reversed with the initial configuration. Had I known what I know now, I just would have reversed the scenes and not pulled it back out and swapped wires. You can have the buttons do anything a scene controller would do. It’s a pretty neat idea.

How to configure and include in your network:
I strongly recommend getting a long network cable and putting Vera on table within a few feet of the switch. I could NOT get it to work any other way.

First, reset the switch to it’s factory configuration. Do this by holding both buttons down for about 10 seconds. At 5 seconds the lights will turn amber. After about 10 seconds, they’ll turn red. Leviton recommends letting the light blink red at least two times before releasing.

In the Vera UI, go to Devices->Add Devices, and select the top option, Add Zwave switch. Select Option 1.

When Vera asks you to include the switch, press and hold the two buttons until they turn amber. Then release. My Vera did not see the device, so I had to select “I’m activating the device but it’s not adding to the list.” Very talked with the controller, then it showed up in the list. I think I also independently pressed button one and button two after it showed up, but I don’t think that’s necessary.

The buttons on the device no longer activate the switches.

Go to your devices and now test the appliance module/lights by pressing the on/off buttons on the device page in UI5. If everything is working here, you can rename the switches to reflect what they do.

Now lets tie the switches to the scene controller for local load activation. You’ll need to create 4 scenes. Turning on button 1, turning off button 1, turning on button 2, turning off button 2.
In UI5, go to Automation->Scenes->New Scene

Call this something like “Turn ON VRCS2 Button 1”. Find the appliance/light control that you just tested and want to associate with button 1. Turn the light on in the scene. Make sure it’s set to IMMEDIATE in the delay settings near the name.

Next select the TRIGGERS tab and add a trigger. Select the SCENE CONTROLLER devices that represents the Leviton VRCS2. Select “A scene is activated.” Put in a name for this (I used “turn on xyz”) and under “which scene number” put 1. For some reason Vera defaults to 0 here, which does nothing. This information was hard to find. Button 1 (top) uses scene 1. Button 2 uses scene 2.

Confirm Changes and save.

Next create a new scene for turning off the same appliance/light control that you just created a scene for turning on. Go to triggers for this scene, and add a trigger. Select the Scene Controller that represents the Leviton VRCS2. Select “a scene is DEactivated.” Give it a name and put in a 1 for “scene number” (use 1 for button one, use 2 for button two.) Confirm the changes and save.

After vera configures the device, you should be able to control the loads with the front buttons. Here’s why this device is clever… Since I had wired the device backward (button 1 to load 2, etc.) I could have just reversed the numbers in “which scene number” and button one would have controlled load 2, and vice versa. I wouldn’t have had to pull the switch and swap the loads.

There is also an alternate way to configure the triggers that I haven’t used but I’ll describe. I’m not sure if there is any advantage to this method, I like the previous method because that’s consistent with every other scene controller, and all my triggers show in once place. After creating and testing your scenes to turn the local loads off and on, you can go to the VRCS2 Scene Controller device and edit the settings (with the wrench icon). You’ll see a tab called “scenes” at the far right. In this tab you can directly select the scenes you want to activate when the buttons are turned off and on. They’re just a dropdown list of all your scenes.

I hope this helps save someone several hours work!


good job !!!

I have two of that running, but I do not create the scenes.

I unable the option “let vera automatically configure devices” and do not activate anymore.

then my inclusion process was equal yours but with this option deactivated I do not need create the scenes to turn on local loads, the local loads works automatically and in vera3 as well.

but the option has stay unable forever…

your post envite me to exclude and rerun all for have that option enable again.

I just finished installing my second VRCS2 switch (first one was a year ago) and these instructions were so handy to have. Thanks for taking the time to write them up.

Been there, done that. ;D However, from memory, my conclusion was that the device is wired counterintuitively, but documented properly and could be considered consistent in the sense that the first load is the red wire; and they picked blue for the second load. The counterintuitive part is that the red wire is at the bottom of the device, and the blue at the top; so you’re naturally associating the blue wire with load 1 (the top button) and the red wire with load 2 (the bottom button).

There is also an alternate way to configure the triggers that I haven't used but I'll describe. I'm not sure if there is any advantage to this method,[...]
I think the difference (whether an advantage or not) is that the triggers are auto-created.

I’m curious, do the LEDs update properly for you in that case? Does instant status work?

@biggsworld - This is an excellent tutorial. It is a beast to get this switch working properly, but your tutorial nails it.

I’m having a delay issue with my Leviton VRCS2-MRZ explained here.

Have you experienced anything like this? Any idea how to fix?

[quote=“Z-Waver, post:6, topic:173950”]@biggsworld - This is an excellent tutorial. It is a beast to get this switch working properly, but your tutorial nails it.

I’m having a delay issue with my Leviton VRCS2-MRZ explained here.

Have you experienced anything like this? Any idea how to fix?[/quote]

I have no delay issues with mine. The relay engagement is nearly instant (maybe 1/4 second? no more of a delay than with my GE switches), but it does take 1-3 seconds for the light to come on indicating that it’s engaged. I have about 15 zwave devices in my network.

The only time I have seen a delay (with GE as a trigger, not Leviton) was in the middle of the night (2am maybe), I turned on a light that triggers a scene to turn on other lights… It was VERRRRY slow to respond (like 10s of seconds). I logged into vera and saw she was running a network repair. It wasn’t something I initiated. I don’t know if she does that every night or not.


I wish they would fix the difficulties pairing this device.

I have one in my kitchen and it keeps disappearing from my configuration (I suspect somebody leans on it until it resets). It’s a pain to not be able to re-pair it without being connected to power and network.

@jbaboval - After you’ve gotten it working properly, be sure to go to the settings tab of the three devices and change the “Automatically configure” drop down from “Use default behavior” to “No”.

Nightly network heals can change routes and reconfigure these devices, sometimes negatively impacting their operation.

I followed the above steps of biggsworld but I am getting a strange problem. The triggers work fine but the ramp rates work like this. The scenes are a simple lights on and another lights off. Lights on is instant reaction to full on as the scene is. Lights off is instant reaction but the lights ramp down over say 2-3 minutes until full off. Anything I am doing wrong here?

@lastmacuser - The Leviton VRCS2 is a combination scene controller panel and local load switch. It is binary(on/off) and does not have dimming capabilities. Are you really using this switch? If not, please open a different thread.

Assuming that you really are using this switch. Then you must be using the scene controller to manipulate a scene/device that has a dimmer attached. If that is the case, the ramping and ramp rate will be configured at the Vera device or the physical dimmer. You need to look there, rather than the Leviton VRCS2. If you need help with your scene or dimmer, please open a new thread.

Also, can you state what brand/model dimmers you are using the VRCS2 with?

Install it and create scenes to turn on local loads because after you include in vera it loses the local load access.
once included in vera you only turn local loads by vera.
then creates a scene to turn on and off each load you have phisically connected.
associate this scenes to each scene button in advanced properties of the device.

I had many problems ate learn this.

Thanks biggsworld - I didn’t create any scenes or triggers yet but the buttons work and the app works. Only one problem but probably not really a problem until I create a scene - I’m getting the famous “unable to configure device” on the _scene controller. I’ll probably just remove and pair the device over again but anyway thanks again.

I spoke too soon.

After pairing the Leviton VRCS2-MRZ - it messed up other lights and sensors - they wouldn’t turn on and the sensor wouldn’t turn them on - also scenes wouldn’t work and nothing worked after installing a backup. Pairing it again didnt help because the buttons on the switch no longer worked and since it’s a light switch well… the buttons should work!!!

Here’s what I did:

I went back to default settings on the veralite I also Reset Z-Wave network - this will make you pair everything again

  • Restore to Default Settings

  • Reset Z-Wave network

  • Reset the switch - by holding down both buttons on the switch (red lights have to blink at least twice)

  • I killed the power to the circuit breaker for about 10 seconds (may not be necessary)

  • As a precaution I reset the switch again (may not be necessary)

At this point you should not see any devices in the vera control panel

Time to pair the device

  • Hit the + include button on the vera (probably wont flash rapidly)
  • Hold both buttons on the switch until blinking amber - 4 seconds
  • Hit the - exclude button on the vera (it should flash rapidly)
  • Hit the + include button on the vera (probably wont flash rapidly)

Wait a few minutes or don’t…

Now in the control panel after a refresh you should see

_Appliance Module _Appliance Module _Scene Controller

We do not want the _Scene Controller (paper cuts in my eyes are more pleasant than this thing)
I’m pretty certain that the _scene controller is whats causing all the problems

  • Reboot the vera
    If the _Scene Controller did not show up for you then congratulations - id still reboot anyway

You should now be seeing two _Appliance Modules

Do with them as you will…

Both buttons on the switch will be working

I haven’t got around to setting up any scenes yet - but if it fails I’ll let you know.

Proof that the buttons work:



Are the LEDs on the VRCS2 working properly?

(The VRCS2 really is a 2-button scene controller that also has 2 built-in switches. The switches can, but don’t have to be, controlled by the scene controller’s buttons.)

Yep it works great.

No problems as of yet.

Here’s proof: http://youtu.be/S5djKXU3M0A

In the video:
I broke the drywall and patched it - needed to put in a bigger box and that’s what happened
but I may be expanding to a 3-gang box because no one makes a 3-way 2 button controller yet which is what i need for the other switches.
oh well

Thanks. Very well. And this is with no scenes defined on Vera (involving the VRCS2), correct?

No scenes as of yet with this switch - well that’s not true.

I set one up for tonight just before I go to work. Yes I work graves.

I’ll let you know how it goes tomorrow.

I setup a scene with a schedule - it works