iVera + iOS5

iOS5 has been officially released.

Did somebody try to update iVera on iPad?

Hi - I also upgraded from 4.2.8 to 5 (production, not beta), and now iVera crashes regularly. It never crashes if I’m connected to the same wi-fi network as my iVera, but it always crashes as soon as I open the app from any other network. The crash happens right after it starts “downloading iVera data”. Any thoughts on if this is a known issue that is being worked on?

I have an iVera2 and an iPhone 4 running iOS5, with the latest iVera app. (I tried restoring to factory settings and re-entering the mios login info, but doing so had no effect)

Installed iVera on brand new iPhone4S. Works fine on Wi-Fi but hangs every other time on 3G/4G with the misleading “Incorrect Password” message

iVera works fine for me on both the iPad and iPhone running the final release of IOS 5.

Hmm. It’s working for me now, too. Maybe an issue they were able to fix server-side?

Can be the case, tested iVera today from work, so far everything works just fine.