Installing an uPNP device

Hi guys,

I have been looking forward to the luup to be able to control my sonos system.

I have been able to extract the upnp xml files from the sonos and upoaded these to Vera, but I do not seem to have any success when adding a device ref “go to the Devices tab and at the bottom fill in the UPnP Device filename in the ‘Add Device’ box and pick a room.”

I have tried

But the added device doesnt do anything. Control by is to “PC” - that is all I can see.

How do I do this correct? Pls help.


What are in the files? These are UPnP Device & Service files? Can you post them here and I’ll try it?


I have attached the 12 xml files - among others the definition xml (zone_player.xml I guess) file with references to the others.

I do hope you can help med being able to control my sonos ( audio system through Vera - this would be a blast for me… :slight_smile:

Let me know how it turns out.



This would be ridiculous, please make it work!


Did you try my xml upnp files for the Sonos?



Tried to use your naming convension with “D_” prefix for device files and here is my xml device output:

The device shows up in device list and I put in the IP adress for my sonos, but I am uncertain if I should set any other settings

<Device_Num_6 Description=“Sonos test Control” UpnpDevFilename=“D_zone_player.xml” Room_Num=“1” Device_Num_Parent=“0” IP=“” Embedded=“1” DeviceType=“urn:schemas-upnp-org:device:ZonePlayer:1” Synced=“1”>

<state_1 service=“urn:micasaverde-com:serviceId:ZWaveDevice1” variable=“LastUpdate” value=""/>
<state_2 service=“urn:micasaverde-com:serviceId:HaDevice1” variable=“Configured” value=“0”/>

<service_16 service=“urn:upnp-org:serviceId:AlarmClock” ControlURL="/upnp/control/dev_16" EventURL="/upnp/event/dev_16"/>
<service_17 service=“urn:upnp-org:serviceId:MusicServices” ControlURL="/upnp/control/dev_17" EventURL="/upnp/event/dev_17"/>
<service_18 service=“urn:upnp-org:serviceId:AudioIn” ControlURL="/upnp/control/dev_18" EventURL="/upnp/event/dev_18"/>
<service_19 service=“urn:upnp-org:serviceId:DeviceProperties” ControlURL="/upnp/control/dev_19" EventURL="/upnp/event/dev_19"/>
<service_20 service=“urn:upnp-org:serviceId:SystemProperties” ControlURL="/upnp/control/dev_20" EventURL="/upnp/event/dev_20"/>
<service_21 service=“urn:upnp-org:serviceId:ZoneGroupTopology” ControlURL="/upnp/control/dev_21" EventURL="/upnp/event/dev_21"/>
<service_22 service=“urn:upnp-org:serviceId:GroupManagement” ControlURL="/upnp/control/dev_22" EventURL="/upnp/event/dev_22"/>


Could anybody help me getting the last bit in place? Anybody with an idea?


Here’s a neat little script for the sonos.


I guess i have figured out that I need a ImplementationFile tag…

Here is part of the TestSerial:


I do not have this in my Sonos upnp Device files. Is this Vera specific?

  1. How should I go about implementing this?

  2. I assumed that as a upnp certified product I would be able to “out-of-the-box-using lua” control the Sonos. Am I going the wrong direction here? Should I keep looking for the upnp device implementation or should it be possible for Vera to automaticaly control upnp devices?

Hope for some guidance…



The implementation file is unique to Vera. It contains the Lua script saying what Vera should do with the UPNP actions. The standard UPNP spec only defines what the actions are, and doesn’t have anything to do with how the actions are implemented. So the question is: What are you trying to do with the Sonos?

I assume you’re wanting Vera to control the Sonos, right? In that case, this is the wrong angle. You don’t want Vera to be a UPNP device. Rather you want Vera to be a UPNP Control Point for the Sonos. Unfortunately, the control point module isn’t implemented yet. So I think you’ll have to wait for us to finish that to do what you want. When it is done, you don’t actually do anything to use the Sonos–you don’t import the files or anything. The Sonos just automaically shows up in the device list.

Ah - I thought I might was doing this wrong… i just want to be able to control my sonos through vera! :smiley:

Looking forward for your control point implementation? Any outlook for eta?

Thanks - anker

Next week we’re going to release the Luup engine to the public (ie non-developers) as an official beta; we finished the translation engine from pre-Luup to Luup engine. So it just depends on how many bugs are flushed out during that beta. Getting the existing functionality solid is our first priority, but as soon as it is, this is next on the list of new stuff.

What ever happened with this? I finally got my zones set up! Must say the S5 ABSOLUTELY ROCKS!!! Oh not to mention Last.FM is the BOMB!

Anker - Did you ever get this working?

Anker, we’ve finished the control point module and it will be available in our next release along with the new UI, with it you should be able to control your Sonos device. We should release a test version most probably at the end of this week.

Now that is Awesome!!!

Look forward to testing it!!!

Me too! Can’t wait to test. Controlling Sonos through something that also controls, lights, security, etc. is perfect. Now for a touch panel that can integrate it all together! Perhaps an Apple tablet on Jan 27th?

Is this in the .985 release if so what the proper way to add the sonos devices?

Any update on this?

I can tell you UI3 see my sonos devices as uPNP and I can add them to the network. I think a device and service file will need to be written for it.


maybe a stupid question: how does Vera see Sonos (I have UI3 installed, too)?