Any way to use imperihome with openluup?

I don’t use Imperihome, but have you tried it? openLuup provides the same facilities that Vera does for access by apps. This is why AltUI works with it, and also the HomeWave app.

Imperihome does not appear to be working with openLuup. I added it as a UI7 system and no devices show on the dashboard.

If you can post a log or indeed a list of HTTP requests made in the attempt, that would be something to start with for debugging. It implements most requests, so I wonder what’s missing?

Of course, remote access through Vera servers will never work.

Imperihome should work fine (tested on Android) - you need to add openLuup to Imperihome as a UI5 system, it will fail to auto-discover so you then just add the IP address of your openLuup install.

I don’t have any Z-Wave devices on my openLuup install (not bridging) but Imperihome seems to recognise plugins like Day or Night and other Virtual Devices correctly, so I don’t see why it shouldn’t work like it does with a normal Vera!

As akbooer said though, remote access obviously won’t work so you should set Imperihome to “force local only”.

Thanks for the rest of the post, but the above comment surprised me, since openLuup is meant to be a UI7 look-alike (with house modes, etc.) There is perhaps a key system attribute which does not match what it needs. Any more information on how you arrived at that work-around? Any useful error messages? Thanks!

Thanks. I tried adding it as a UI5 system, but imperihome kept finding my existing UI5 system and forcing me to use that one. I have opened a support ticket with imperihome to see if they can help me get it working too.

I can try a hail mary by unplugging my vera system and then add in the openLuup system first and then re-add the vera system.

I think it’s just the way Imperihome works when you add a “system”, there’s nothing wrong on the openLuup side IMO.

Imperihome lets you choose between adding a UI6/UI7 system or UI5. Both start out by asking for remote credentials, but you can skip that step and it then “detects” Vera. I’m guessing it must use UPnP discovery to do this, which might be why openLuup isn’t detected?

It then seems to force you to choose one of the detected systems, but you can also input a direct IP address if it doesn’t detect anything. When I tested, it found two Edge test boxes so I couldn’t add it using UI6/UI7, but adding as UI5 didn’t “discover” anything so I was able to add the IP address manually, if that makes sense.

Just re-reading localuser original message, as I may have misunderstood what the problem was:

I added it as a UI7 system and no devices show on the dashboard.

This sounds like openLuup was actually added OK?

You do know that the “dashboard view” in Imperihome is blank by default, until you add stuff to it?

Maybe try switching to “list view”?

Indeed, one of the things that openLuup will never do is UPnP, which makes a bit of a nonsense of its name, but there you go.

Imperihome is working for me now as a UI7 device. I had created a bad device and once I fixed that it loaded.