Icons disapearing from home screen.

Thank you for a great app. I love it, especially how customizable it is.
With that being said, however I run into weird issue.
I created 6 control buttons on the home screen so far on my iPhone.
4 of them are in top row and 2 in second row.
Now whenever the app is closed and restarted the top 4 buttons are fine but the 2 in a second row loose their icons.
The buttons are there but the icons assigned to them disappear.
Is this a know issue? Can I fix it somehow?

I have noticed the same thing when creating a button that has a text label overlayed on an icon - when the app is closed and then reopened, the text stays but the icon disappears. This bug seems have have been introduced with the latest version of HomeWave.

I have also noticed this with the latest version… :frowning: Seems random, sometimes the icons stay, other times they go away after you close and reopen them. Also have noticed that saving the configuration, and using it on another device, different icons go away…

I was seeing the same thing. I change the size of the icon to the “Size to Fit” option and it seemed to fix it but that may have just been a coincidence.

I tried this and it works. Thanks for the tip.

I haven’t been able to reproduce this thus far, but others are reporting it too. Can someone perhaps post step by step instructions that recreate this problem (including the icon file used)?

Very easy to replicate. I added the “light bulb” icon to a control button. Works fine as I continue to use the app. Go to any other app, then return to the HomeWave app - icon still there. BUT… if you quit the Homewave app completely and then restart the app - icon is gone.

One other piece of data for the test, at least in my observation is the icon was inserted as Actual size. I didn’t observe the problem when I switched to Size to fit.

Yep, same thing here. Really annoying.

Since I switched icons size from actual to “size to fit” as suggested by simdude I no longer have this problem. Even when I switched back to actual size they work fine now.
Those icons I choose were the ones included in app and whatever the problem was changing the size seems to fix it.

Looks like this is due to a something introduced in an iOS8 patch. Saving images works fine in iOS 7.1 but fails in 8.1 (unless you fiddle with the properties).

It looks like changing the size isn’t necessary. I managed to make images get saved by adding them to a control, then closing and opening the property screen for that control a second time, then saving the config.

It also seems to happen only for certain image files (such as the ones included in the app), or for some images added from the photo album. Has anyone experienced this issue with other images (loaded from Dropbox)?

I think I have coded a workaround, but this still needs a lot of testing; image handling is nasty stuf…

Can only confirm that I have the same issue on 8.1.

I also experience problem with the icons not being in line. See attached snapshot. It might be lack of knowledge on my side though… :wink:

I’m using the app on an IPad-2 and my 4G IPhone…The IPad is mounted in a wall and app runs 24/7 so I rarely have issues.

The iPhone always loses two of three icons I have created on the home page nearly every time I open the app. The page link remains as well as the title I assigned but icon is gone. I have to go in and manually assign the icon again to each. I’ve tried the “size to fit” indicated above. Mine has even started to lose the wallpaper pic I assigned to the home page as well. If I go to any screen and then return to the home page the background picture returns.

Love the app but would love this issue fixed…Kind of embarrassing to open the app to show it off and 1/2 is missing…