iBlinds Questions

Good morning,
I recently purchased a bunch of iBlinds modules for Black Friday, and I’m in the process of getting them installed in the blinds throughout my house. I’ve started with two thus far, and I’m already having an issue. The first one I installed, I got the following error: “Failed at: Setting special association…”


Can anyone tell me what this means, and what I need to do to correct the issue?

Second, even the second one I set up, appears as above, minus the error. Vera sets them up as dimmer light switches, which is sort of annoying. There is no on/off for these devices per say, so the on/off light bulb is meaninginless.

Is there another definition file for blinds?

Lastly, one of the other smart home blinds product out there, which worked off of bluetooth…can’t remember the name for the life of me, had a sun tracking feature. As it was bluetooth, it was tied to iOS or Android OS, so it did the heavy lifting. Has anyone developed a plug-in or luup code that could do something similar? For instance, I may want to have my blinds open, but if the sun is at a low angle on the horizon, it’ll shine right in my eyes, either in my bedroom in the morning, or in my office in the afternoon, so I’ll want to adjust the angle of the blinds to block the sun, but still let in light. This of course depends on time of year, so there would have to be some computations going on.


For clarity’s sake, what I’m looking for in the last paragraph is a way to calculate azimuth (measured clockwise from true north to the point on the horizon directly below the sun) and elevation (easured vertically from that point on the horizon up to the object) of the sun, so I can integrate that into making triggers in PLEG, or other similar apps (reactor).

Are these mains or battery powered? I suspect mains, so this probably won’t help, but the first issue might be caused by the blind failing to wake up to get its configuration if it’s battery powered


Yes, they are battery powered. They have their own propreitary battery, that needs an initial charge before being used of at least 8 hours. I plugged them in last night before 6 pm, and attempted to configure at 6:30 this morning.


So, I just checked my system again, and the error disappeared. Looks like Vera fixed itself!

On the other hand, I did hear back from iBlinds support. According to them, in their lab environment Vera detected the device as a window covering.

Looks like something needs to be changed in the configuration. I’ve emailed Vera support, so we’ll see if they can assist.

Might have been that the device woke up. Typically battery devices only wake up every few hours so the configuration can take some time…


Vera recognized my first iBlind as a window covering, the second as a dimmer. So I changed the device_type, device_file, and device_json of the second device to match those of the first, which worked. (Perhaps not all these changes were necessary but I frankly don’t know enough to know which was the important one.)

Seems like a logical solution!


I just changed mine to D_WindowCovering1.json and D_WindowCovering1.xml. That changed them to window coverings, but it does not show the battery as indicated by iBlinds support.

Battery will come the next time the device wakes up. Or when the device decides it needs to update the controller with its battery level. It all depends on how the iblind device firmware was written. You could also manually wake up the iBlind device which should then update the vera.

The mechanism is as follows:
The UI shows battery only if the device has a BatteryLevel Variable.
This Variable gets created when the vera gets a Battery Level Command class frame from the zwave radio.
The zwave radio gets that frame only when the device sends it.
The device sends it when it wants. Normally when polled, or when the battery level has changed by more than a certain %. The vera currently automatically sends a polling frame when it gets a wakeup frame so that’s why waking up the device should get you the battery level.

Highly recommend to set the wakeup interval to be very long on these devices or you will wipe out its batteries in a hurry. The vera has the nasty default behavior to change the device default wakeup interval to an insanely short number (1800) upon initial configuration. I would recommend to either find out what the default was and set it back to the default or at least use 43200 (12H).

And yes both the device json and the device xml files need to be changed for the device to be changed to a window covering. The device type field will be changed on its own upon luup reload when the two file fields are changed.


So, I’m getting very frustrated with these and Vera. I can’t get Vera to do exclusion mode to save my life. I’ve had two switches fail on my in the past week, with Vera support on the phone, and their only solution is to buy a new switch and take back the old one. The iBlinds devices I added this morning aren’t functioning. I tried going into exclusion mode to start over, but Vera never signals that the device is exludeded. I’ve tried add #3 of 10 devices, and it’s not functioning either. I’m guessing the D_WindowCovering1.xml and D_WindowCovering1.json files are not the correct files. I’m getting a successful sent command, but nothing actually does anything.

Any advice? I’m so frustrated right now I just want to throw Vera in the trash and start over with something else.

I was one of the original iBlinds backers and have 10 installed on my Vera Plus. All of them are working flawlessly automated via Reactor with manual control via an Aeotec Nano remote. During setup, I had one blind that needed to be reconfigured but I was not able to exclude it from the installed location that was about 30 feet from my Vera Plus. I pulled the entire blind down with the iBlind actuator installed and carried it over to my Vera Plus - while in close proximity, I was able to exclude it easily. Once excluded, I hung the blind back in the window about 30 feet away and reincluded it. Overall, I am very impressed and happy with the iBlinds. Maintain faith and persistence and you will be rewarded. Even my wife likes them :wink:


What you are observing is a bit odd and I would agree with @blacey to use some patience here.
Take a deep breath and

  1. Before excluding, try reconfiguring the device but at a closer range. Hit the configure the device now from the advanced menu and wake the device up manually. If the signal is weak, maybe change the battery.
  2. If excluding is what you really want to do, the brute force way is to factory reset the device and delete it from the vera without exclusion. Actually, if you try to include the device which was not factory reset but deleted from your vera, it will still work and the vera will tell you that you are including an already existing node and try to configure it. Which will come down to practically the same thing as the configuration in bullet 1.

If the vera says the command was successfully sent then it maybe a problem with the device being able to respond but not programmed correctly. It should mean that the device received and acknowledged the command but for example thinks it is already open or closed when you ask it to open or close etc…

Thanks all. The distance to the controller seemed to be the contributing factor. I have a fairly large z-wave network, so distance has never been an issue installing devices, as in theory, each z-wave devices is a repeater. That may not work the same when removing devices. The weird thing, is that the devices did add, but just wouldn’t communicate.

A while ago, one of the Vera support agents created a clean-up scene for me to run when I had issues. I ran it, which effectively cleaned up and rebooted my Vera. Then I started trying all over again.

I brought my laptop down to the basement where the z-wave controller is located in my network cabinet, and brought one of the iBlind devices that was failing to remove itself from the controller. This time, it removed itself! Not sure if it was the proximity issue, or the clean-up scene, but I was able to remove the device, then add it again. This time, the Vera software worked and successfully controlled the blinds! I repeated the step for 5 more devices, all with success. I still have 4 more devices to install, but I believe I’m on the right track.

The devices are only showing up as dimmer switches for now, but do function. iBlinds support confirmed that on their lab, with the current Vera firmware installed. They said it used to install as a Window Covering, but something seems to have changed on Vera’s end. They’re going to be reaching out to Vera support to see what happened.

I think you’ll find that for initial inclusion and configuration (and exclusion) you need direct communication with the controller, not via a repeater. It’s normally pretty well stated in the manuals. Never quite got it myself until I understood that the initial ‘key’ exchange needs to take place between the controller and the device direct (at least I think that’s what it’s called)


I am seeing the results of that, but I still don’t understand why the devices actually did show up in my Vera console, but weren’t controllable. I mean, I found the solution, and as you said, it’s well stated in the manuals, but I just wouldn’t have expected the blinds to be recognized by the controller, but then not function.

The MyIBlinds support tech I’m been working with also noted that when he went to test install a device using his Vera setup, that currently they are not being recognized as window coverings. He stated that on a previous Vera firmware revision, that the Vera controller recognized the blinds properly, as Blacey and shlesher stated. The device recognition seems to be a recurring issue with Vera. I have some GE Jasco switches with motion sensors that Vera has promised for about 2 1/2 years to have native device integration, but still don’t. The last time I asked, they didn’t seem to know what I was talking about.

My guess is that the actual configuration is a bi-directional process and is slow (compared to what we’re used to) so the device is seen but then takes several minutes for the correct config to show. If that process is interrupted or stopped somehow you end up with a busted device.
A further guess that some devices are more complex than others, and may, perhaps, have more information to exchange between controller and device before complete understanding is achieved. I’d hazard that these blinds are at the more complex end of the scale given what they are capable of in terms of continuous movement, and reporting of their position. Compared to say a door sensor which is either open or closed.

Or I could be totally wrong!

Totally agree about the flakey recognition! It has been said this will be fixed. Certainly there are many more devices on the ‘Works with Vera’ list. I had little problem adding a stack of stuff last week with teh caveats of being pretty much sat on top of the VP and with good batteries in everything.


I’m 80% there. I have one blind that isn’t responding, but I believe this is an issue with Vera. I had tried to add it at one point early, and then tried to unpair, but the original blind still shows up in Vera. I’ve tried deleting it, but it’s still there. I can’t get rid of the bloody thing, and I haven’t received a response from Vera support to assist. I believe since it’s the same device I’ve tried to add again, it’s having issues (conflict or such). I’m hoping to receive some word from Vera today.

I’m now starting to set up scenes through PLEG. Does any body know how to set the blind to a specific position? Unfortunately, because of how Vera sees the blinds, it’s Open/Close or On/Off seem the be essentially the same thing: the blinds closed 180 degrees of each other. Is there a way to make Open the 50% setting through luup code?

Is there a way to reset the iblind? It still has the Vera’s key so will keep showing up when it’s powered on. Deleting on a Vera doesn’t do what you might think it does.

Or you need to do an exclude from the Vera and start again.


Actually, I did exclude/reset the device to get it to be recognized by Vera, but the old one is still there on my dashboard. I’ve tried unpair and delete, and it just won’t go away. I’ve had this happen a few times in the past with other devices, and I’ve had to get Vera support to remove them.

Bet they just hid them :slight_smile:

You can do that in AltUI