Howto use/configure local Lan ports on vera3?

I want to connect an ethernet Relayboard directly to my Vera3, but i could not configure/“connect to” the board.

My local network settings are;

Could somebody help with configuring the networking settings so i could use the ports?

Useful background reading:,9264.msg120603.html#msg120603

I’ve read a lot, found the advanced settings wiki (which shows more options then i have in my adv. set.), found a lot of post on this forum, etc. but no post that tells me how to connect an ethernet device to these ports and let the Vera talk to them.

I read on the forum that you think that domotica devices show run separated from your other network devices.

This is what i want; See attachment
But i can’t get it work so, my question is; could/should it work?

And the images in the post you suggested are not working.


Please see attached and see if this helps.

[quote=“Brientim, post:4, topic:181038”]Hello,

Please see attached and see if this helps.[/quote]
This work in the way that my devices are now in my local LAN (192.168.1.XXX), but i want it to be in the Vera’s (V)LAN(192.168.81.XXX) so only Vera could communicate with these devices and so the are isolated from the rest of my devices/LAN.

Sorry, I miss understood the original post.
If that is what you require, the first posts settings were correct.
Your Vera will assign an the IP address to connect LAN ports within the range at the bottom of that page

You can then verify allocated IP address through Network tab and DHCP tabs

Ok, could happen ;D

But the settings in my first post didn’t work, or i’m expecting somethings else or…

The connected device is in DHCP mode and after i change the settings, i rebooted the vera, started an SSH session and tried to ping the connected device without success. I tried the IP’s and non of them responded.

Is there a way to find the leased IP of the connected device?

There’s a file on Vera called /tmp/dhcp.leases which might contain what you want.

As per the previous attachment, the next after the switch tab is the DCHP and should contain the leases.

While typing this post i saw your posts…

I was looking/discovering the OpenWrt GUI and found “Network”>“DHCP and DNS”>“General Settings”>“Active Leases”.

Active Leases Hostname IPv4-Address MAC-Address Leasetime remaining ? 00:xx:xx:xx:xx:xx 0h 55m 16s

So the strange things is;

In the vera GUI the DHCP settings are; LAN DHCP server On Start address 100 End address 150 Lease time 60m (m=minutes, h=hours)

And the connected ETH device leased IP: and thats outside the configured/expected range…

See attachments.

Bug ?

Oh, probably. The Vera DHCP server (dnsmasq) has been hacked up compared to vanilla OpenWrt and possibly ignores the OpenWrt config files.

You won’t find a lot of drive in the community to fix this. Most users are either too wary of Vera’s dnsmasq to use it at all, or are happy to have their devices get any old address.

Actually it looks like MCV may have a typo in there settings. If you look at the OpenWrt settings it lists the max allowed leases of 150 clients. So that means the dhcp leases will go from 100 to 250. The MCV settings shows the end address as 150, but I think it should be the number of ip leases to hand out.

  • Garrett

oo yeah, i see… :-\

Although i think its strange that the first lease is at 206, i was expecting 100 or 101.
Also i think its strange that MCV not shows the DHCP leases and if a persons is not familiar with SSH and/or the OpenWRT GUI its almost impossible to know whats the IP of the connected device.

I vaguely recall that dnsmasq has a mode where it hashes the requesting MAC address to produce an IP address that is stable over time. Perhaps that mode is enabled.