How to restore Z-wave network? Restore is failing.


So I was trying to get my z-stick to be a secondary controller, and in the process, I seemed to have deleted / zeroed my z-wave network on my Vera Lite. I would like to restore from backup.

But, if I try restore through the UI, it says:
Restoring backup: 1391551028.tgz
Start unpacking backup files…
ERROR: Failed to unpack the backup

So now I can’t restore and I have no devices. I assume this isn’t right. How do I fix it? And while I’m at it, is there a way to restore the Z-wave network only? I have set up SSH access, so I thought I could overwrite the file with what is in the backup, but I think you still need to get the z-wave devices onto the Z-wave chip.

Try downloading the backup file again.

Try a backup file from the previous day.

There isn’t a way to restore the Z-Wave network alone. You check the box to restore the Z-Wave network along with the Vera restore.

Had the same thing happen to me, had to got back 2-3 days to find a backup that worked.

Gone back over a week, still nothing. Weird thing is the file unpacks on my Mac without any problems. And the error comes up on the Vera almost immediately, which seems like it isn’t even uploading the file to the Vera.

Does anyone know where the file might be stored on the Vera to be unpacked? Maybe uploading it through SSH would work? Another thought, could it be a browser issue? I’m using Mac Safari, but have Chrome and Firefox too.

Not GUI-accessible; but Tech Support can do this, reportedly.

It absolutely could be a browser issue.

Try Mozilla.

It works with Google Chrome, had the same problem with Safari.

sorry to bring an old thread back to life, but I had this problem too. The solution was to decompress and re tar/gzip it and THEN it worked. I just double clicked it in the finder to create the ?etc? folder and then from the command line did a tar -cvzf somename.tgz ./etc

I uploaded the resultant file to the vera lite and it accepted it. Evidently for archiving they are using an incompatible version of gzip or tar.

i tried and i tried, tens of backups. zipped, unzipped. automated backups and manual backups. 3 different browsers like Chrome, Firefox and even IE, but every time the same errors.

vera gives me the failure every time again:
Restoring backup: 1430412297.tgz
Start unpacking backup files…
ERROR: Failed to unpack the backup

manually created backup (no extension file) unzipped, rezipped, nothing seems to work. sometimes i get other errors like “requested entity too large”.

i have lots of devices, some scenes and i really dont feel like re-adding them all. the backup i have, just NEEDS to work.

somebody with a different idea than the solutions already mentioned? vera support doesnt even reply to the ticket. it has been open for days now…and i seriously cannot do anything with the vera right now…

I’m having the exact same problem. My Vera 2 got into a state where I’d create a new scene and it would ‘vanish’ after the final ‘save’. Tried many things and finally decided to factory restore and restore from backup. Went through linking to my account again then tried to upload the backup - failed to unpack files. Every single time. Have tried dozens of backups. None will work.

Just to let everyone know, technical support sorted it for me. I couldn’t manage it myself.

+1 on the recompression fix. Trying Chrome didn’t work, but using the suggested solution above, tar -cvzf somename.tgz ./etc, from the terminal after unpacking the originally compressed file to get the ETC folder, worked just fine.