How to install motion detector Foscam Camera

Please excuse my absolute ignorance but I have installed a Foscam Camera and video is great, however I have no idea how to “install” or engage the motion detector to trigger things.

I have searched the forum but I think I am so clueless I cant even search it effectively.

Am i supposed to create a new “sensor” device or should it have automatically created.

Please Help… (I hate being new :-[)

In the Foscam device click the wrench and select advanced go down to “state” set to one (1) close window and click save at top of screen wait a bit, refresh screen and the motion sensor will show up. Welcome to VeraWorld.

Cool…that got me somewhere…

However now I have this error on the thumbnail???

open foscam device and enter vera IP under gateway (in advanced)

OMG…I am gonna poke my eyeballs out with a rusty fork… :cry:

I changed all the network settings in the foscam as suggested and still same error…It seems I am in for a wild ride with this Vera…

Below are my Foscam settings…my vera is set to 192.168.1.3

For the vera outdoor sensor you need to start a url which makes a change on your foscam. It is somewhere hidden in the foscam thread

You changed the wrong place. Undo what you did and in vera>foscam device>click wrench>advanced tab>scroll down to Gateway Address or VeraAddress and enter Vera’s IP. Question-did the impl file pick up Foscam or Vistacam? If vistacam other changes are req’d. Don’t use the rusty fork because colour braille monitors are hard to find.

You changed the wrong place. Undo what you did and in vera>foscam device>click wrench>advanced tab>scroll down to Gateway Address or VeraAddress and enter Vera's IP. Question-did the impl file pick up Foscam or Vistacam? If vistacam other changes are req'd. Don't use the rusty fork because colour braille monitors are hard to find.

Foscam

You have to put in the username and password in vera/foscam device>settings (near bottom of window) and then save

You changed the wrong place. Undo what you did and in vera>foscam device>click wrench>advanced tab>scroll down to Gateway Address or VeraAddress and enter Vera's IP

I don’tseem to have any settings for “gateway/vera address” under advance tab for camera settings??? :

It appears that vera has not fully configured the cam and motion sensor. Could you delete them from vera and configure the cam itself under basic network settings to the attached parms and then start again. The missing items will appear once the cam is set up, then, when functioning, establish the motion sensor. What is the version of the Foscam plugin that you are using? (vera>Apps>myapps).

Crazy Stuff… ???

I entered “2” in the state field and the motion sensor came right up…

[quote=“cfnardone, post:12, topic:177429”]Crazy Stuff… ???

I entered “2” in the state field and the motion sensor came right up…[/quote]

Yes , i did the same too , but now the motion sensor is there it doesn’t work , it says no implementation .

Crazy Stuff..... ???
I entered "2" in the state field and the motion sensor came right up.....

Yes , i did the same too , but now the motion sensor is there it doesn’t work , it says no implementation .

My other Outdoor Foscam Cam did that too. I kept changing small things, deleting and recreating, and then eventually I changed the device type of the associated camera as attached below with a “2” instead of a “1” and it came up…

Edit:
I also found that link as Crismaison suggested and ran that at some point.

THANKS TO ALL BTW!!!

Crazy Stuff..... ???
I entered "2" in the state field and the motion sensor came right up.....

Yes , i did the same too , but now the motion sensor is there it doesn’t work , it says no implementation .

My other Outdoor Foscam Cam did that too. I kept changing small things, deleting and recreating, and then eventually I changed the device type of the associated camera as attached below with a “2” instead of a “1” and it came up…

Edit:
I also found that link as Crismaison suggested and ran that at some point.

THANKS TO ALL BTW!!!

[url=http://forum.micasaverde.com/index.php/topic,11472.0.html]http://forum.micasaverde.com/index.php/topic,11472.0.html[/url]

SOLVED

Must use STATE = 2 to get LUUP to create the Motion Detector

  • after you set this, and press the red SAVE button, you will see a status message at top of the screen, “Reload Luup to create motion sensor”

There is NOT a “Gateway” option under ‘Advanced’ tab until AFTER you set STATE = 2

After you set STATE=2 and RELOAD LUUP you will get the new Motion Sensor device AND the STATE will be set to 1 on your IP Cam.

… don’t you wish the app developer would have taken the 30 seconds extra to make this documentation when they released the app!

Sorry for the thread necromancy, but I have the same issue.

After I install my Foscam, change the state to 2 and reload LUUP (http://ip_address:3480/data_request?id=reload) I get a Motion Sensor. However, I also get a “Foscam Camera : Failed to configure camera” error message. I can still use my Foscam device but it says “Lua Startup Failure”.

I tried to add the Foscams IP and MAC in the advanced settings of the created Motion Sensor, but this did not solve the problem.

Has anyone got the created Motion Sensor to work properly (and not broke the camera device in the process)?

EDIT: Here is my log when restarting the Vera:

50 05/28/14 1:12:40.346 luup_log:264: (GAMLA KÖKET) State=1 <0x2c399680> 01 05/28/14 1:12:40.430 FileUtils::ReadURL 0/resp:401 size 140 http://192.168.1.31:80/set_alarm.cgi?motion_armed=1&http=1&http_url=http%3A%2F%2F192%2E168%2E1%2E21%3A3480%2Fdata%5Frequest%3Fid%3Dlr%5Ffoscam%5Ftripped%26sensor%5Fid%3D265&user=vera&pwd=ramses22 __LEAK__ this:45056 start:1019904 to 0x14bc000 <0x2c399680> 50 05/28/14 1:12:40.431 luup_log:264: (GAMLA KÖKET::State=1) Failed to configure camera, status = -1. <0x2c399680> 01 05/28/14 1:12:40.431 LuaInterface::CallFunction_Startup-2 device 264 function lug_startup failed GAMLA KÖKET with return false <0x2c399680> 06 05/28/14 1:12:40.432 Device_Variable::m_szValue_set device: 264 service: urn:micasaverde-com:serviceId:HaDevice1 variable: CommFailure was: 1 now: 1 #hooks: 0 upnp: 0 v:0xeaa438/NONE duplicate:1 <0x2c399680> 01 05/28/14 1:12:40.433 LuImplementation::StartLua running startup code for 264 I_FoscamPTZ.xml failed <0x2c399680> 02 05/28/14 1:12:40.433 UserData::AlarmCallback ALARM_RESYNC_DEVICES <0x2c399680> 02 05/28/14 1:12:43.043 RAServerSync::SyncDevice alt 0 response 200 url https://cms1.mios.com/sync_device?PK_AccessPoint=35107213&HW_Key=MfMCIKnujl8itvwvkrpIt5qP043b5nA1 with 32436 bytes __LEAK__ this:307200 start:1327104 to 0x1507000 <0x2c399680> 02 05/28/14 1:12:44.102 ZW_Send_Data node 2 NO ROUTE (nil) <0x2c599680> 04 05/28/14 1:12:44.424 <0x2c199680>

“GAMLA KÖKET” is the name of the Foscam.

[quote=“n0ir, post:17, topic:177429”]I tried to add the Foscams IP and MAC in the advanced settings of the created Motion Sensor, but this did not solve the problem.

Has anyone got the created Motion Sensor to work properly (and not broke the camera device in the process)?[/quote]

Did you ever get this to work?

The best solution for this is to use BlueIris on a PC to handle your recording and motion detection and have Vera get the feed (including pan/tilt) using the BlueIris plugin. I have a 12 year old PC with 2GB of RAM running 6 camera’s just find. There are many other advantages of using BlueIris, just search or ask.