how to cancel a arm delay with rfid keypad


I am using a zipatp zwave RFID keypad to arm my system.
Works out of the box on Vera UI7.

When I arm the system with the keypad the exit delay starts.
Now it is not possible to stop the delay with keypad. (using the home button and RFID)
I have to wait until the system is armed and then disarm the system.

Has someone the same problem with a zwave rfid keypad?



I use the same device.

I’m not an expert, but you can manage the delay time when you switch HOME to AWAY, using the keypad.

I think by default it’s 10 seconds.

and when you switch AWAY to HOME, it’s immediatly



Thanks for your answer.

I use an exit intervall of 30 seconds.

When I arm the system with the RFID and AWAY the delay starts.
After 5 seconds I notice that I forgot something.
So I want to stopp to arm the system.
When I now use RFID and HOME nothing happens. The exit delay continues and the system arms.

So I can not stop the exit delay with the HOME Button and RFID.

Do you experience the same issue?

thanks and regards,

I have the same problem. I don’t find any solution for the moment.

maybe somene else… ?


I got this answer from customer service.

I did some checks and this device is not integrated into our system and that?s why it has limited functionalities. I will open a case for integration for this device but in order to have it integrated, we?ll need to have the logs on how the device works. So I enabled Verbose logging on your unit from Settings → Logs and please exclude and re-include the keypad and after that press each button on the device and let me know the date and time of when you performed all of these actions.

I did as asked and keep you updated.


Oh great… Hopefully their changes don’t **** up how it works now.
I’m happy with it

Can you create a Scene that Triggers on the Home button on the keypad to set it back to Home? If you call LUA code to set it back to Home I believe it cancels the delayed progression to Away.

You add this code snippet to swithc to Home mode to the LUA area of the Advanced Scene editor (when you get to the end before you do the final save on the Scene editor):

luup.call_action(‘urn:micasaverde-com:serviceId:HomeAutomationGateway1’, ‘SetHouseMode’, { Mode=1 }, 0)


Problem ist that there is no Trigger on the home button. There are only triggers for away and pin code entered (but this event triggers on the home and the away button).

To cancel the delayed progession you have to use (got this info from customer service) this code. Just to change the mode does not stop the delay. But I did not try because there is not event available to trigger the scene.

function cancel_hm()



luup.call_delay( ‘cancel_hm’, 1)[/code]

A few days ago they told me to set the exit intervall to 1sec and intervall before reporting a motion, door, window tripped to 10 sec.
I will try if I can close my house door in away mode within this 10 seconds without raising alarm. Do not think so but if customer service suggest this solution? maybe?

Keep you updated if this is the solution.


Hi Turtle.

Did you solve your problem? I have the same issue and might start trying what you discribe in the latest post… I know ist been a while tho since then…

// Filip