HomeSeer HS-WD200+ Support on Vera

I recently purchased a HomeSeer HS-WD200+ assuming the LED status light is supported by Vera, but I was wrong. I purchased this device in hopes I could utilize the led lights to tell me the status of Vera. ie: away=show red led light, home=show blue led light, etc. But since the led light configuration is not supported in vera, I am stuck. I know from researching, the end user can config the led lights using LUUP but I am new in that area. Does anyone have any writeup as to how to control the led light in vera either thru LUUP or other means? thanks in advance

I was able to get it to work via the use of luup and pleg via the change of device parameter with the following code:
I have copy/paste the code into pleg under device actions =>LUUP, i hope this helps:

luup.call_action(‘urn:micasaverde-com:serviceId:ZWaveNetwork1’,‘SendData’,{Node=‘57’,Data=‘112 4 21 1 1’},1)

57=device number, it is the altid number
112=leave as is
4=leave as is
21=parameter# to change first led (the bottom light)
1=leave as is
1=change led to red color
1=leave as is

see page 4 of this pdf for a listing of parameter codes to the led color of your choice

Thank you for sharing. But, can you not just put the code into the scene definition where it says, “Also, execute the following Luup code:”? That’s what I tried, so far, with no success.

Has anyone gotten multitap (central scene command class) working on vera with the HS-WD200?

I was tired of waiting for multitap support and have managed to get it working by using a custom device JSON. I have attached files for the WD100+ and the WD200+. The button presses can be used as triggers for scenes. One caveat is that it does not directly work with PLEG. A suggested workaround can be found here. Seems to be working very well for the short time I have been testing it.

Homeseer Multitap JSON (6.3 KB)

Thank you for doing this, cannot wait to try it out!!

I tried these out, great work, exactly what I’ve been hoping for two years running! Thank you @liteman!!!

I followed @liteman’s lead and used his pattern to create the Homeseer switch versions of the json as well (based on the binary switch device). The WS100 version works well, but i’m not able to test the WS200 (don’t have one yet). Hopefully these will be of some use.

Homeseer Multitap Switch JSON (5.7 KB)

Is anyone else having trouble lighting the LEDs on these dimmers? I tried the following in “Test Luup code” and it appears to run successfully but has no effect. (My HS-WD200+'s altid is 2.)

luup.call_action('urn:micasaverde-com:serviceId:ZWaveNetwork1','SendData',{Node='2',Data='112 4 21 1 1'},1)

Am I doing something wrong?

Edit: Yes, I was doing something wrong. Or rather, I wasn’t doing something I should have done. After going to Device Options and setting variable 13 to a value of 1, the above command now works. This is required to put the LEDs in Status mode.

Please see my new plugin which includes much better support for HomeSeer wall devices.

New scene controller plugin