Help needed! UI4 doesn't load data properly?

Hello, ever since I upgraded to UI4, I’m consistently having problems connecting to Vera and Vera’s WiFi keeps rebooting randomly. Here is a screenshot of what I keep seeing in Vera. I’m more likely to have this warning than actually connecting to Vera. I’ve tried rebooting Vera but unfortunately I haven’t had any luck at all.

Can you provide more details. Have you had any success getting access to vera after the upgrade? How are you accessing vera via or from the actually ip address of the unit? Are you using Vera as your main router or is it hooked up to another router? Do you have physical access to vera that you can hook it up to the computer via one of the ethernet ports?

  • Garrett

This issue occurs no matter how I access Vera. I have tried to connect the device directly to my pc as well as using it as a switch behind another router. I am no longer using vera as a switch b/c of the random rebooting every 45 minutes or so. Also, my scenes are almost broken at this point b/c Vera doesn’t seem to be executing them properly. I didn’t have any of these problems with UI2, only after upgrading to UI4. I may have to downgrade to UI2.

Sounds like the upgrade did not go too well and is causing these bugs that you are having. Can you afford to do a clean firmware install?

  • Garrett

sure, I haven’t installed everything yet b/c I haven’t gotten vera to work properly. How do I do a clean install? I have tried resetting vera to factory settings and still have the issues.

Also, Vera keeps having server busy messages and the only way to remedy this is to reset Vera

alfonsec, why don’t you go to advanced, tech support, and enable the back door. Then submit a trouble ticket and include the code. One of our support guys will login to see what’s wrong.

I did that almost 2 weeks ago but I never received a response. I just filed a second one this morning.

This is the problem that I’m having too. Resetting doesn’t work. I have requested to RMA the unit back to Smarthome. It worked great for a short while but I installed the media manager and a GE45601 remote and then could not get the unit to cleanly load UI4. I sticks and will not finish loading.

I have a lot of faith that the Vera2 will be my solution but I think there are some strange behaviors by this box in particular.

Micasaverde: Contact me directly and I will give you the info about the vera2 unit (S/N) so you can identify the unit from Smarthome to resolve the issue.

I hope the replacement works better.
Current Setup (RMA’d’) :
(8) X-10
2413u PLM
2 Intermatic HA03 Lamp modules
GE45601 remote

On Order:
Replacement Vera2
Schlage Deadbolt
Trane Thermostat
5 Intermatic HA03 Lamp modules
1 GE 45606 Z-Wave Technology 2-Way Dimmer Switch

Mine is acting this way too. It also wont boot up while I have my serial stuff attached either which I think is an issue that occurred when I ported from my V1

I saw that the two people who are also having the same problem as I am both have devices connect to Vera and I have the insteon 2412u connected as well. I tried removing the Insteon device, but unfortunately it didn’t make a difference. :frowning:

Anyone manage to get their Vera working properly?


This is an issue with the firmware version. I am having the same problem with reboots. My problem is not as severe as yours but I’m waiting for the next firmware rev due in 1/2 weeks. This is supposed to fix it.

The other resolution is to go back to an older UI…
I spent a couple of days to get the latest version of UI4 to load. I left it run overnight and it now works but marginally with the reboots.
I almost RMA’d my Vera due to this issue.


Mine comes up but I still have to disconnect my serial stuff when I reboot it (which is every day or so due to it hanging) and then plug it in again after the Zwave comes up. I’m thinking about wiping and starting from scratch.

Do you have a lot of plugins etc loaded?

I saw another post where people had rolled back to an older version because they were having reboot issues (i think it was 1.1.103X or something) and it fixed their stability issues!

Edit See the thread below for further details.