Having trouble on the Android side

The Android component of Vera Alerts is not really working for me. I had originally purchased a cheap used phone to wire into whole house audio made with computer speakers. The messages started to come with a delay and they were broken up. There would be pauses in the middle of some messages, some lasting several seconds and some times (usually) the messages would simply not be spoken. Thinking that the phone may be a little low on horse power I switched to my Asus Transformer as an experiment. It worked well for 1/2 a day but then it stopped speaking the messages all together. So I set it back to how it was originally, turning the wifi off when the screen is off. Since I have heard three spoken messages when turning the device on but otherwise it hasn’t spoken a single message. I have the same results if I manually run a scene which uses Vera Alerts, so I’m assuming that this isn’t a problem on the Vera side of things. My phone may be under powered. I don’t know much about phones. It’s an LG Vortex if that means anything to anyone.

Ideas? Is anyone else experiencing similar issues?

I have a bug on the android side I need to address.
You need to set the phone up so it does NOT go to sleep.
I need to keep the phone awake while messages are queued.
Otherwise it wakes for a fraction of the message and goes back to sleep …

Sorry for my ignorance, but, how does one keep the phone awake? This is the first Android phone I’ve tinkered with so I’m at a bit of a disadvantage here. I have looked for settings that would do such a thing as I had considered this as an issue, but to no avail.

So, I am sitting here with the phone on in my hand and I manually run a scene which should send TTS to the phone. I immediately see the message on the phone but there is no TTS. Occasionally the TTS will function. I have max message count, message repeat count and message repeat delay all set to 0 and override alert tone is checked. The odd part is that the behavior is unpredictable. There is no pattern. It does speak sometimes but not usually. And the receipt of the message always seem to be lightning fast.

What versions of Android OS ?


Does anyone have any ideas about this issue?

I have now wiped the phone and started from scratch five times. Each time TTS works for a couple days and then slowly it stops working entirely. But the notifications always come instantly. I have it set to vibrate on receipt this time around and as soon as a scene triggers an alert the phone buzzes but no TTS.

I have not had a chance to look at it. Nor do I have a phone with that version.
Have you tried just rebooting the device.
That version might not be cleaning up the TTS resources properly.

Well, it’s behaving the same way on my tablet running Jelly Bean also.