GETing a url, what is going wrong?

I can’t believe how difficult it is to hit a friggin URL from my vera.

I’ve tried:
os.execute(“curl ‘http://user:pass@insteon:25105/3?026224FFF00F1300=I=3’”)
os.execute(“wget -q ‘http://user:pass@insteon:25105/3?026224FFF00F1300=I=3’”)
os.execute(“curl ‘http://user:pass@’”)
os.execute(“wget -q ‘http://user:pass@’”)
And several more variations I’n not going to list here.

yet, from vera’s own shell prompt: this works:
root@MiOS_50022594:~# wget ‘http://user:pass@insteon:25105/3?02622947AA0F1300=I=3
Connecting to insteon:25105 (

I’ve administered Linux systems for 20 years. If it doesn’t work when I try this hard, it’s not me that’s wrong. Where’s the feedback? Where is the error code? “Scene run failed?” oh yeah? prove it. TELL ME why it failed. Show me the proof that it failed vera. What syntax was invalid? Something, other than flatulance, please.

Why am I resorting to a community web forum, in 2022, nearly a decade after this product “launched”?

1 Like

Hello @ui677fik ,

Could you please enable remote access and provide the name of the scene you are trying to add the URL to, so we can take a look?

Thank you.

Thank you Alvaro!

50022594-995856 (SSH: 25873 TS_SRV=vera-us-oem-ts11)

The Scene is called “All Lights Off” in the room “No Room”.

Luup code currently reads:
os.execute(“curl ‘http://user:pass@insteon:25105/3?02622947AA0F1300=I=3’”)
os.execute(“curl 'http://user:pass@insteon:25105/3?0262256ECA0F1300=I=3”)
os.execute(“curl ‘http://user:pass@insteon:25105/3?026224FFF00F1300=I=3’”)

But of course I did try, and would prefer to use luup.inet.wget over using os.execute

You may have to hit a url to test, use this one:
http://insteon:25105/3?026224FE350F1300=I=3 That will send an off signal to the least disruptive light of them all.

If I’ve caused luup wget to not work somehow I’ll gladly fall on my sword here. I’ve put significant work into maintaining a very organized network. DHCP reservations and forward and reverse DNS set up for nearly every host., is a 2242-222 ethernet based insteon hub/modem device. It does the same thing that their USB/Serial PLMs do, but over ethernet. This lets more than one device use it without moving cables. In fact, I use it just fine from a VM in another state that runs a windows app they released a decade ago to do diagnostics on the insteon network, and those diagnostics complete succesfully, so the PLM is definitely working, and is in no way dependant on their cloud, which has been gone for a few months.

If you wget by IP from the MiOS bash commandline on the vera, it turns the lights on and off as expected.

We ended up trying the following one:

luup.inet.wget(‘http://user:pass@insteon:25105/3?026224FE350F1300=I=3’,1) and it worked as intended, however, can you verify if it is actually doing something on your end?

Otherwise, we can try to change another setting, and then you can let us know the results.

Note: the scene executed successfully.