General troubleshooting anonymous devices

I’m getting a bit worn over the years troubleshooting devices that for whatever reason lose connection, or can’t be configured, and can’t be identified. The reported errors are usually something like “Waiting for wakeup to configure device”, or “Device failed to configure”, or some such, and waiting for even months or years is of no use. Help searches and Vera support give various solutions, often for specific devices, and usually not working. Attempts to Unpair don’t work, since you can’t tell which device is being referred to, and attempts to delete just result in additional errors.

  1. Is this just a general failing of z-wave products?

  2. Is there any way to add an option to truly unilaterally delete a device, that works and gets rid of it from Vera?

  3. Is it possible to provide a general purpose troubleshooting that works and doesn’t require support tickets?


This is rather a question than a specific bug report/feature request so I will move it to the appropriate sections.

Now to answer your questions:

  1. No it is not a general z-wave product characteristic. It is a failure from vera to recognize and test how badly they have overloaded the zwave network stability by adding a lot of zwave traffic through functions they call maintenance which were never designed to be maintenance and are rather massive hammer on the network to be used only cautiously. The course has only been reversed on the latest firmware (7.30). See this thread.
  2. Yes, the delete device function of the vera does just that but your device needs to be reset as well or it will come back on the controller when the device broadcasts its homeID to be the same as your controller’s
  3. This forum and all the folks here should be able to help you.

Hello, having a similar problem which I will lay out below.
I have motion sensors from Sylvania (ZigBee). I add them as generic ZigBee devices and after they are configured by Vera, they show up as Centralite motion sensors. No issue there as they work as they are supposed too. They report both temperature and movement.

One of the sensors stopped working. The sensor itself seems to still function. (the little led inside lights up when it detects motion) but it no longer reports anything back to the Vera.

The battery life according to the Vera was over 90%.

I tried removing the battery (still thought I was having a better issue) and the device still shows up on the Vera. Ilthe battery has been out fo .over 12 hrs but the battery indicator for the device on the Vera still shows over 90%.

Basically, it doesn’t appear that the Vera knows that this device is offline. Not sure how to force an update or do.any further troubleshooting

Any ideas?

That’s normal. If you take out the batteries then the device can’t send a message to the vera to signal that it is out of battery. However after some time, the vera should say that the device can’t be detected. Why not swap out with new battery? The battery report is based on voltage and is often not accurate. It depends a lot on what type of battery you use because they have a voltage vs. usage profile which is non linear. Ex: Lithium Ion battery will maintain very high voltage until suddenly dropping. NiMh will start low and degrade slowly until going potentially negative, Alkaline will be more linear but vary in rate depending on brand… etc.

“It is a failure from vera”

Thanks. At least there is hope that it will be fixed one day.

“Yes, the delete device function of the vera does just that but your device needs to be reset”

I’ve read that many times over the years. But unfortunately, Vera won’t tell me which devices need resetting. It’s an anonymous list, that has an unknown mapping to actual nonfunctioning devices (I have a lot of devices). That’s the point of my entire post. So, I simply want to delete them all permanently. Then, I can go around and trash the devices that I discover are no longer functioning. Costly, but at least I’d have a workable plan to get rid of the mass of errors Vera has been constantly reporting over the years.

“This forum and all the folks here should be able to help you.”

I’ve made extensive use of the forums over the years (to which I’m grateful). I’ve been in touch with support. My post is only because none of that has worked. I now simply want to get rid of the errors and move on, but even that seems to be impossible. I’m hesitant to move to a different z-wave platform, as I’m skeptical they will be any more robust, and the switch would be costly (in my time).

Anyway, it sounds like you are saying that there is NOT a single one-stop-shop troubleshooting plan for these particular kinds of errors. I suppose that’s why Vera has never published one.

Thanks for your kind reply.

Now I am a bit confused by your description of anonymous and not knowing which devices have failed. The failed devices show up with a red tag and message on the UI. The top message is anonymous but the dashboard should show you how many on the top menu and if you click on it, will give you the list of failed devices. I am never confused about which device is having a problem.
The only other thing I am imagining to be possible is not having named the device and allocated it to a room at the time of inclusion. In that case it is up to you to configure the devices one by one so you can recognize them.

So I tried changing the battery. Waited for fresh batteries to come in before changing. I wanted to make sure that the batteries I used were full.

In any case, changed the batteries, waited an hour, and didn’t see any difference. Motion sensor is still reporting the same temperature and no movement. I tried soft rebooting the hub and no luck there either.

Anyway to force poll the device or force an update?


May be completely different, but the temp sensors attached to my Fibaro universal sometimes stop updating. Only solution is an update to a previously working backup, and then not always, in which case it’s exclude and include :frowning:

Might be different for these devices


I just deleted the sensor and am now trying to re-add it. It’s a nightmare.

Ok, so I finally have it back up. I had to delete the device and then re add it. At first I wasn’t able to re-pair the device. I was using the Generic Zigbee wizard. Then I switched to the Centralite Model 3 Sensor wizard and it worked, saying that it was expecting a Centralite device, but sees a generic Zigbee device instead. It eventually configured itself. Once it was done, it is now working properly, except the battery is being reported at 10%. Unfortunately this triggers an alert on the dashboard every minute or so and I’m not sure how to turn that off.

One thing at a time I guess. I’ve turned notifications off so even though it is creating an alert, I’m not getting bombarded with notifications. Would love to disable that feature or find a way to reconfigure the way the battery level is detected.

The descriptions in vera are generic and identical. I can’t tell which failed virtual device corresponds to which physical device. I can only tell, e.g., 8 devices have failed in Vera, and 8 physical devices are not working. It has something to do with Vera being unable to get data from the devices, apparently. Most of the devices are really pretty new, BTW.

I have, since first I posted, repeatedly deleted the failed devices in Vera until now it seems that they have stopped reappearing. So, maybe I’ve solved that problem (until it happens again), and can move on to the lengthy and costly task of identifying, throwing away, and replacing all the corresponding physical devices.

Although, frankly, I’m growing weary of maintaining constantly failing HA systems, and may simply give up. Even Lutron and Control4 take years for their professional contractors to finish a job (I’m assuming they one day will). HA really is ridiculous, although I will continue to use whatever doesn’t fail.

“In that case it is up to you to configure the devices one by one so you can recognize them.”

They were all working fine initially. All named, and all in their correct room assignments. I suspect it had something to do with my misguided “upgrade” to Vera Secure.

I do not know from what you upgraded from to get to the Secure. I understand anything older than UI7, which would mean older than Vera 3, or those that never left UI5, may have trouble upgrading the hardware. In that case, a complete rebuild of the system would yield better results.

In my case, I had a Vera 3 for a long time, running UI5, then UI6, and eventually running UI7 and rebuilding my system from scratch a few years ago. When I purchased a used Vera Plus off eBay in November, I did a restore from my Vera 3 backup and it worked great for a while. I ended needing to kill the wi-fi and it has been humming along fine.

I am not sure exactly where your issues are rooted, but if you upgraded hardware from real old firmware to the secure, you are likely to see problems.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules