Garage Door Opener help!

So I can see the device in vera correctly, but it is not triggering my door.
Since I have a Security+2 GDO, I was planning on using the solder to remote idea.
I have a jackshaft GDO (Liftmaster 3800), so I bought a Liftmaster 378LM wireless wall control and was planning on mounting just inside the door so I would have a second button near the door to close when walking the dog etc. (so I don’t have to do the “push button, run to closing door, hurdle sensors” routine).
When I shorted the solder leads on the back with a wire to figure out which ones to solder to, the door opens or closes.
Here is the weird activity: When I touch the same leads with the wires from the GoControl, it also opens and closes the door. This seems to indicate that the GoContol closes the circuit even though I haven’t activated it through the app. I.e. the circuit is closed by default. I would think that it should be “open” by default and only open/close the door when I activate it in the app.
Is my GoControl faulty?

I would tape down the leads to the remote and test how it works. It might not matter as I am guessing it is the momentary pulse that triggers the door action. Whether is is open-close-open or close-open-close may be irrelevant once the connection is made.

Remember since this was originally designed for a wall button, closed-open-closed is probably the correct operation for the GoControl. Since usually those wall controls need power (even if it is just to light up the button on a dumb button). And the GoControl is going to need power from the remote so closed as the default state seems right!. Not telling how quickly you will burn through batteries though.

You might want to search for “Battery Eliminator” on Amazon, there are some cool hacks that will allow you to put in a dummy battery in the remote that you can then plug into a wall wart for powering the remote and GoControl.

Hmm now that I think about it you may end up with the remote constantly sending out a signal like the button is constantly pushed down and that might be problem. You can switch it using a dry contact relay (usually can be had for under $15) but you need to also get an in dependent power supply for the GoControl (probably 12v not sure how much power the GoControl is expecting). All in all might just be easier to use something like the Fibaro or Mimolite z-wave relay which supports dry contact and just solder that to the remote instead.

taping it didn’t work…It just continuously opened and closed.
When I activate it via the app, I don’t get the warning flash and beep either.
I would expect that to happen, even if it was not attached to the GDO or remote.

Here were the steps some else used Linear GD00Z working but not working

And here is a really good thread with pictures on how to wire the remote and connect in line with a relay https://community.smartthings.com/t/linear-gd00z-garage-controller-and-wall-switch-with-motion-detector/8919/24

Thanks!
I initially disconnected the wall control from the GDO and connected the GoControl directly to the Motor expecting it to work with no response. I think I’ll try again.

Scroll through that thread on smart things you may have to add a resistor between in some applications but the post lists the correct part to use and everything.

Connecting it directly to the motor should definitely work. Did you get the beeps and the flashing light from the GoControl? If not, you might need to re-pair your tilt sensor.

Success!!!

I got it working. I soldered leads to the circuit board of a remote. When I touched the leads, the door opened/closed so I thought I was going to have issues when connecting to the GoControl.

To my surprise when connected the leads to the GoControl wires, it worked perfectly.

I could not have done it without the help of everyone on this thread, so thank you! Thanks to @leedavidr for sharing a picture with the settings, Urodoc for bouncing ideas back and forth and specially to @shallowearth for asking the right questions and pushing me in the right direction.

Good to see that there are still plenty of people out there willing to help others without any personal gain.

Here’s a pic of the final set up.

https://imgur.com/gallery/0ufZHKp

Hopefully this thread will help someone else in the future.

Having finally been able to get mine to work, make sure that you get the beeps and the flashing lights when operating it through Vera without having the white wires connected to anything. I thing that’s what’s causing your GD to operate it continuously when connected to the remote. My remote operated continuously as well if I touched the leads soldered to the button, but when I connected the leads to the white wires on the GoControl, it didn’t close the circuit until I activated the GoControl via Vera.

I hope this helps.

I’m not getting the beeps and flashing lights when activated through vera. I contacted gocontrol.
They seemed to think it had to be vera or my garage door controller. The GD00Z-8-GC was tested before it was shipped so there was “no way it could be the issue”.
They suggested trying another hub or garage door controller. ;-p

Well, I tried again. I changed all the parameters after setting it to manually configure (i.e. manually setting the device_file to D_BinaryLight1.xml and the device_json to D_GarageDoor_Linear.json, and device type to: “urn:schemas-upnp-org:device:BinaryLight:1").

Still no love. Then I switched the auto configure setting to “yes” and tried again.
Success!!!
Now I have flashing lights and beeping!
On to the install…

Thanks to all for this thread, couldn’t have configured my GD00Z-5-GC without the information. Thought I would pass on my experience for others that may follow.

Followed @Urodoc lead and things were working great in VERA. However, I use HomeAssistant to control everything and could not get VERA to respond to commands from HA. After a lot of tinkering and research discovered that HA uses the “category_num” and “subcategory_num” in configuring/communicating with the VERA integration. So, I changed the “category_num” to 32, consistent with @leedaidr config, re-loaded the VERA configuration in HA, and now everything works as expected. With the added bonus of now the little picture in the VERA device settings is now a garage door instead of a lightbulb.

Only downside is that I don’t believe that VERA is able to use the secure S2 connection, but I can certainly live with that.

This little project now allows me to finally get rid of the flaky MyQ controller.

BTW, I used the mcavoya’s mod to the GD00Z-8 in this thread https://community.smartthings.com/t/how-i-made-linears-gd00z-4-work-with-liftmasters-myq-door-opener/49768 to get things working with my LiftMaster MyQ garage door opener.

I just got a GD00Z-8-GC opener for Christmas. Like many of the others who have posted here, my Vera controller recognizes it but not correctly as a garage door opener. Following the steps posted as Urodoc it ends up being a generic device with no ability to control anything (no on/off or lock/unlock options).

One difference between myself and the OP is that my firmware is 1.7.1040. Unfortunately, this is the newest version of firmware I can load on my old MiCasaVerde controller. Is it possible that one of the files referenced above (D_BinaryLight1.xml or D_GarageDoor_Linear.json) are missing in that version of the firmware? Is there any way to get this device working?

Don’t know how much help I can be but will give it a shot.

With respect to the firmware, I am on the latest so cannot help on that. If the interface is similar, you can look in Apps->Develop Apps-> LUUP files to see if they are available. There I can see all of the referenced files (e.g. D_BinaryLight1.xml…).

The best advice I can offer is to have patience, it took 5-6 tries of adopt/configure to get things working properly. Couple of notes I found particularly useful:

  • Unpair (or delete and reset the GD00Z-8) between attempts.
  • The Step of turning off the automated configuration seems to be important. And then after the changes turn it back to on/default.
  • I had to refresh the screen to see the change in the icons. Don’t know if there is a time variable to that bit, but it was not immediate
  • The pairing process was much quicker/reliable with the device close to the controller. Although it worked fine while in place in the garage in my final attempt
  • When I got to point of receiving “Please wait, getting the manufacturer”, I just unpaired and started again. This happened twice for me. Best practice seemed to be to follow the parameter change process before attempting to use the device.
  • Operating the device manually (with the wall pushbutton) was necessary before the GD00Z was able to control. Although I think this is specific to my mod to make it work with the MyQ opener

while it was a bit of an exercise in patience to get it configured, so far it is working fast and flawlessly in my configuration.

Good luck

Thank-you… I did not know about Apps->Develop Apps-> LUUP files. I do not have the D_GarageDoor_Linear.json file so I’d guess that’s my biggest issue.

Truth be told, I’ve been upset with Vera ever since they suddenly decided to no longer support my controller. This morning I ordered a Hubitat. Hoping I have better luck with that device.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules