Foscam controls no longer work with UI5

You can edit the file yourself and reverse the lines for the controls.

  • Garrett

Thanks Garrett, I just don’t see how to invert the image. Thanks.

To invert the image, you need to log into the Fozcam camera web interface and change the image setting. It should be located near the ptz controls.

  • Garrett

Ugg. Duh. Thank you.

I cant get the P&T buttons to work?
I’m running Vera 2 with UI4 - 1.1.1338. I have video displaying ok with a FI8918W. I’ve downloaded MCVFlorin’s I_FoscamPTZ.xml file and then uploaded it to the Luup files where it can be found. I’ve pasted this into the impl_field, but nothing happens when I press left/right, up/down? The “command failed - no implementation” message is gone and nothing seems overwritten even if I do power cycle on Vera and the camera but the buttons just don’t work. I’ve tried with IE9 and Google Chrome with no difference.

The foscam originally installed with the generic IP camera plugin. I’ve tried deleting that, downloading the Panasonic PTZ plugin and pasted in I-FoscamPTZ.xml file without success. I gone though the various related threads but can’t see where I’ve gone wrong - any suggestions?

Use this file. This works with both UI4 and UI5.

That fixed it. Thanks ;D

Upload the last version of the file, visible in the lump file and changed in the impl_file in the camera.$$Video is working but the command are not responding.

Vera 1.5.245 and foscam camera.

Thank you for support

I logged an issue yesterday with MCV support about my Vera Lite and some camera issues that I was having. I received an email response from one of the MCV tech support team members. He indicated to me that l_FoscamPTZ.xml only works on UI4. What was odd, and likely scripted, was that he followed that statement up with a link to the Foscam Wiki page which says to include the l_FoscamPTZ.xml file in the Foscam camera configuration.

Rather ironic, don’t you think? :slight_smile:

I just got my Foscam camera today and added it to my Veralite running latest UI5. Pan/Tilt didn’t work so I uploaded the I_FoscamPTZ.xml file and then set impl_file to I_FoscamPTZ.xml. After reloading, I still do not have Pan/Tilt working. I looked in the log file but didn’t see anything.

Did I leave out something?

What Foscam camera model do you have?

[quote=“mcvflorin, post:51, topic:169938”]@rrlance
What Foscam camera model do you have?[/quote]

Foscam FI8910W

have have the same model, the only way i can get my foscam to work is with the the icam view server, no PT though

I have the same foscam 8910w and have not been able to get the p/t features to work… Can someone please help or find a solution to our problem.

Do you get the No implementation message, or pressing the buttons just doesn’t do anything?

If pressing the buttons don’t do anything it means that the commands for the Foscam FI8918 are not compatible with the FI8910. To find out what commands your camera uses you need Firefox with the Firebug addon installed:

[ol][li]Open the camera control panel (not from Vera UI).[/li]
[li]Open Firebug, the Net tab. If this tab is disabled, enable it.[/li]
[li]Press the button to pan the camera right while watching the Net tab.[/li]
[li]Copy the URL used to pan the camera right and paste it in a new browser tab, to make sure it’s the right one. If it’s not, try every single URL from the Net tab until you find the right one.[/li]
[li]Repeat for the other directions.[/li]
[li]Post here the URLs you found, so I can update the Foscam plugin.[/li][/ol]

Here is what I got

Right /decoder_control.cgi?command=4
left /decoder_control.cgi?command=6
up /decoder_control.cgi?command=0
down /decoder_control.cgi?command=2

That’s what the Foscam plugin uses currently, so it’s strange that it doesn’t work. Maybe that camera doesn’t like the onestep parameter which is added to the URL. Try this URL and see if it works:


I also have a Foscam FI8910W that does not have Pan/Tilt/Zoom when accessed through Vera2 with UI5. I only installed it last evening, so I do not have a great deal of experiencing using the camera, but I certainly now have a great deal of experience installing it. (It was quite and adventure.) I was surprised after completing the Foscam official installation, and beginning the task of installing the camera in a Vera2 environment, that my Vera2 saw it with no intervention on my part. However, although my Vera2 saw the device, the parameters that my Vera2 saw were the parameters that I completed during the “wired” phase of the Foscam installation, not the “wireless” phase. Because of this the MAC address of the Foscam device in Vera2 was incorrect. I corrected the Foscam device Internet data and added the l_FoscamPTZ.xml to the device Impl Advanced Settings field. The camera functions well in the Vera environment with the exception of no P/T/Z.

My question is: Would it make sense to delete the device and let Vera2 reacquire it? Hopefully, after the reacquisition, the Vera2 parameters for the Foscam device will be the “wireless” parameters. If this makes sense, how does on go about deleting the Foscam device and letting my Vera2 reacquire it?

You should not have to delete the camera. If it is functioning (you have a camera image), all you need to do now is figure out the correct ptz controls for the camera to modify the I_FoscamPTZ.xml file.

  • Garrett

[quote=“mcvflorin, post:57, topic:169938”]@dinosinc
That’s what the Foscam plugin uses currently, so it’s strange that it doesn’t work. Maybe that camera doesn’t like the onestep parameter which is added to the URL. Try this URL and see if it works:


thanks I will give it a try and see what happens