Foscam controls no longer work with UI5

Having issues as well.
Uploaded file. Restarted Luap
Added file name to impl_file filed under advanced tab of camera
Still getting “No Implementation” error for panning and tilting. (Streams video fine)
Foscam FI8918W Wireless IP Camera
UI5
Firefox browser and tried IE8
Reloaded browser, etc

@markbannister

Check that the file name is spelled correctly. Remember that it’s case sensitive.

[quote=“mcvflorin, post:22, topic:169938”]@markbannister

Check that the file name is spelled correctly. Remember that it’s case sensitive.[/quote]
Cut and pasted from Lua file list so looks good.
I get an “Ergy[46] : Startup Lua Failed” when lua starts – is Lua halting before it gets to all the files?

The ERGY error shouldn’t have anything to do with the Foscam not working, but uninstall ERGY just to be sure.

Didn’t help.
There are a couple of old cameras installed that I can’t delete for one reason or another. They use these files:
Old camera 1
urn:schemas-upnp-org:device:DigitalSecurityCamera:1
D_DigitalSecurityCamera1.xml.lzo

Old Camera 2
urn:schemas-upnp-org:device:DigitalSecurityCamera:1
D_DigitalSecurityCamera1.xml

Could these be causing problems? Would it help to try and delete the camera and start over? (It was added under Ui4 or ealier)

edit - one of the old cameras I try and delete says “Command Failed invlaid plugin”

You can try to delete those camera devices using the method described here:
http://forum.micasaverde.com/index.php/topic,9052.msg59279.html#msg59279

[quote=“mcvflorin, post:26, topic:169938”]You can try to delete those camera devices using the method described here:
http://forum.micasaverde.com/index.php/topic,9052.msg59279.html#msg59279[/quote]
OK that worked for the non-existing camera. Figured out what was going on with the other. Vera is adding them back automatically-didn’t know it did that and didn’t know the other old camera was still connected.
So Deleted all cameras, the Foscam and the other got added back automatically. Put the “I_FoscamPTZ.xml” line back in the Foscam impl_file variable.
Same issues.
Looking at luup files I have all these mentioning cameras:
D_DigitalSecurityCamera1.xml
D_DigitalSecurityCamera1.json
S_Camera1.xml
S_DigitalSecurityCameraSetting…xml
S_DigitalSecurityCameraSetting…xml
S_DigitalSecurityCameraStillIm…xml
S_DigitalSecurityCameraStillIm…xml

Is it possible any of these are causing issues?

Did you upload the I_Foscam file remotely? Look to see if the file was actually uploaded.

It’s in the list of luup files.

I just tried this (remotely via Safari) Vera stated the file upload was successful and Luup restarted, but the file is not in the list of files after the restart. I tried it twice with the same results.
So it appears remotely uploading does not work?

JOD.

@JOD

Unfortunately no. See here: http://forum.micasaverde.com/index.php/topic,9035.msg59900.html#msg59900

Right. I wanted to validate the comments of 'Device not ready" was due to the fact the file did not exist after the upload when done remotely. Confirmed.

I just uploaded it locally and the file exists and Pan & Tilt works.

JOD.

Got it working
Changed the IP of the camera and manually added it. Added the impl_file variable.
Now it works. The variables available for the new camera were different from the existing one.

Worked great! Thanks!

-Michael

I’m confused completely. Help set up the camera. Attach a screenshot. The points. Thank you.

problem help me

The IP address field must contain only the IP:port pair.

Anyone have any ill experiences with the latest Foscam FI8910W ?

Thanks!
Doug

Thats the cam I have and the above instructions works for me.

mcvflorin’s file worked great for my 8910w. Just mounted it upside down. Does anyone have the file with the image and ptz directions reversed? thanks!