Foscam controls no longer work with UI5

I am not sure if I changed something. But my up down and side arrows no longer work with UI5. I am still pointing to the revised XMl file that has the Foscam commands in it??

Added by mcvflorin

If you upgraded from UI4 you must install the Foscam IP Cameras plugin from Apps >> Install Apps. If after installing the plugin the controls still don’t work, open the camera control panel (click on the wrench in the upper right corner of the device) >> Advanced tab and make sure that the impl_file field is I_FoscamPTZ.

@Ermanr, there seems to be a pregnant pause in the forum in regards to Foscam controls not working in UI5. I’ve been waiting for someone from MCV to either acknowledge that the problem is real or provide the corrective procedure to rectify the problem. I’ve asked repetitively in a number of different thread with no resolve. Mike

Same thing here. Upgrade to U15 breaks the pan/tilt function in the modified LUUP file. I have also confirmed that the correct file is still in place.

Any help appreciated!

-Joe D

Getting similar with UI5 and Foscam. UI4 everything worked fine with Foscam. Now pan/tilt isn’t working and video is very intermittent. Works fine viewing camera directly (w/o vera UI). When video does work it works for a little while then gets a “film strip” graphic, i suppose indicating that it didn’t get an image.

Why the hell don’t we have an out of the box driver for the most popular/cost efficient camera currently available?

Especially since it does automatically detect the device via UPNP and add it to the system - with the wrong (generic_ip cam) device instead of the correctly modified panasonic device?

that would be awesome. if it worked correctly

Upload the attached file on Vera, then open the camera device CP >> Advanced tab and enter I_FoscamPTZ.xml in the impl_file field. I don’t have a Foscam camera to test this, so let me know if it works.

Edit: The pan left and pan right commands were reversed, so I fixed it and reuploaded the file.


The PTZ Foscam file works great. I have to create another one with reverse controls as most of my cameras are mounted on the wall and are upside down.

  • Garrett

I must be slow on how to successfully load new xml files within UI5. I go to my “Luup Files” and in the “Upload Files” section, I use the browse option to select my new I_foscamPTZ.xml file that download from @MCVFlorin. I select GO and I get the following message (below the Upload files title) “Thu, 05 Jan 2012 21:08:38 -0500 ====== START ======” but when I look in the current files I do not see my new file name. I went ahead and changed the impl_file name to reflect the new file however when I try to move the camera I get the message “Device not ready” which reflects that I have not uploaded the new file. Any clues as to what I’m doing wrong? Mike

When uploading the file, did you check the box to restart the lua engine?

  • Garrett


What browser did you use?

@garrettwp, Yes did it both ways.

@mcvflorin, I used Mozilla Firefox as my browser

Worked great for me with Chrome browser…

I told you I was slow… In my feeble attempts I loaded Google Chrome with the same resolve as IE9 and Firefox browsers (was unable to upload the new xml files). I ended up rebooting VERA which fixed the problem after that I got a better result “Upload successful” message. As mention earlier make sure you select "Restart Luup after upload and/or do a “RELOAD” (Top right of screen). I too created a second file (named it I_FoscamPTZrev) as I have a camera upside down and needed both right/left and up/down controls reversed, quite simple to do; simply create a copy of the file provided by @mcvflorin and change the value in each line for each direction e.g. in the Move Left code in the next line… look for “decoder_control.cgi?command=4&” and change it to a “6” look for the Move Right code and change its value from “6” to “4” do the same for Move up and down. Mike

I am having a problem finding the impl_file feild
device CP >> Advanced tab and enter I_FoscamPTZ.xml in the impl_file field

When I go into the camera under advanced, I have a different name for the feild that has the xml file name.

Also, has anyone figured out how to create a scene that notifies you with a digital still when it senses motion.

thanks all


Can you post a screenshot of the Advanced tab?

Here it is


impl_file is usually between room and date_created. See if you can find it there.

oh boy. it is there but the feild is empty. So now I changed the name in the wrong box. If I delete the device, will it get reinstalled with the defaults again so I can start over?


What box did you change? If you changed the device_file box, then this is the default value: D_DigitalSecurityCamera1.xml


thanks a bunch