Firmware upgrade & Memory issues

Sorry to be the bearer of bad news but this error you are reporting are a sign of either your flash drive having bad sectors or your partition having run out of space. I would recommend to either try extorting or try the savespace script in the flash partition thread. It is unlikely to be fixed by a firmware update. Best case, you may have a memory leak and are running out of ram and this would be due to some plugin or scene errors.

I have memory monitor running and there is always ample free memory reported. Mios support has never mentioned bad sectors and out of the 25 remote support session I assume that have been gathering information to make this diagnosis if they suspected this to be the case. The unit no longer seems to be reporting the cannot write user data system error but now locks up a couple of times a day and I have to manually powercycle the unit to get it to respond again and get light etc working again.

@PrincessCleavage, Really sorry to hear but it is all indications of corrupted data. I would suggest to read the links I posted. This type of issues are not uncommon with the vera and are addressed in these threads. I have observed bad sectors on my flash drive increase over time.

I might be incorrect but my understanding of flash drives is that depending on the quality of the flash drive they generally has spare sectors for when the eventual used sectors have a predicted failure and given the unit is about 15-20 months old, would this be expected behaviour for a Vera edge unit?

I had it happen on my VeraSecure that was only 4 months old, it eventually locked up to where even support couldn’t get into it remotely, luckily it was warrantied.

This is true only of SSDs which have a modern controller, not for all flash drives. The MT7620A in the vera edge has some of these functionalities but… if you read into the flash useage thread, the drive is very poorly partitioned and any wear leveling and TRIM will only occur within that partition space. The partition is tiny and I calculated that the rough lifetime of that partition for an average system would be 2-3 years on the plus before complete failure. It is worse on the Vera Secure and a little better on the edge only because of the couple of extra megabytes the vera can use. If you have plugins and a lot of devices, the amount of logs and user data overwrite increases and the lifetime decreases. In spite of using SLC NAND which is deemed very reliable, vera’s very poor partitioning and usage of the flash drive just absolutely kills it. I explained it at length in these threads. This is why I strongly recommend extrooting your vera even if you are not out of storage space.

Is the script in your second link to move files on a Vera edge still relevant with the new firmware or has the new firmware addressed the poor partition architecture?

I don’t want to be completely absolute in my response but from how I see the firmware is designed and how the upgrades work, no firmware upgrade can modify the partition structure. It requires lower level utilities the vera does not have. For the vera edge, you do not have a big unused space like the plus and the secure do so extrooting is really the only way. Make sure you have backups.

Traditionally I try to avoid ex-rooting but will explore

For the life of me I can not find any attached script in the exroot thread, am I overlooking something?

It’s at the top of the first post in the thread. Not showing for you?

It wasn’t him/her. It was me not having attached the file. It got lost with all other attachments when the forum moves as you know… I attached it after this post.

Yeah, @PrincessCleavage PM’d me. It was, of course, there by the time I went looking for it. Just trying to be helpful. I like that you put it in the head post. Although many of us do that with the durable files, I think we should make it a “best practice” here.

As far as I know, devices are capable of taking (exchanging) the secure class key only during inclusion. This is why the vera rightfully asks us to exclude and re-include.

To me, the process was not different from before. Am I wrong?
(I unpaired a device from my well functioning HomeSeer network and included it again in the Vera network)
For that reason I would like to check what mode it has been included in to state a final verdict. How can this be done?

I got very helpful support to clear my memory the other day. An old plugin (dataMine) had left large files when I removed it.

You will have to use ALTUI. Inside the device menu, there is a configuration tab which can tell you whether the security class has been configured. Unfortunately, a lot of information is missing from the standard UI7.
Under nodeinfo look for:

1 Like

I am back online and your solution worked!

Apps are not un-installing. Unless they are somehow being re-created by their devices.

Also, I have internet connection, but the controller is always offline?

Philips Hue Bridge not working. PHilips Hue Bridge: I’ve tried both HUE II and the ALTHUE APPS. Does it work natively? I’m using HUE because of the death of Wink and the fact that I use Cree Bulbs for certain lamps around my home. A bridge to Hue allows me to have them work together and I eventually want to use it with Google Home, along with Alexa.

I have been thinking of a Secure to replace my 3 for over a year. Rebuilding my logic is what is stopping me, assuming restoring from backup will be full of problems. If 3’s and Lite’s do not get firmware updates, I may still just hang onto my 3 since it is very stable.